Camera Timeouts and USB traffic

Hi, all,

I’m trying to diagnose some (seemingly random) camera timeouts I’m getting with my ASI 1600 MM pro camera. Reading some of the older posts, it seems this could be related to USB traffic, so I tried to decrease the USB limit down to 40. That seemed to help, as the night before, my dragscript ran successfully for almost 7 hours, capturing frames across two targets.

But last night, the same dragscript terminated after only 30 minutes. Looking at the logs, I see recurring camera timeouts. I only noticed this in the morning. So, without touching anything (in case some cables were loose), I tried disconnecting and reconnecting, and Voyager could successfully grab exposures in OnTheFly mode.

I’m not sure what’s causing the timeouts. If it’s USB traffic, I could turn down my USB limit even further. But I noticed that if I reduce the USB limit to 20 and click “Ok”, and then open up the Camera Advanced Config dialog again, the limit is reset back to 40. Has anyone else run into this? Can the USB limit not be set to a value less than 40?

Anyone have any other suggestions on how to diagnose this further? For instance, if there are additional diagnostics that I can enable? I have new USB3 cables. I also have all my equipment (ASI 1600 main camera, ASI 178 guider, focuser and mount) connected to a powered USB3 hub. My laptop is a Surface Go (with a dual-core Pentium Gold processor and 8 gigs of RAM) running Windows 10 Pro.

Thanks for any help,

  • Rajeev
1 Like

Hello Rajeev,

inferior limit of USB depends on camera model. You must set it and press button Save if you use ASI Native Driver Voyager implementation. Timeout mean the connection was down … this can be the USB limit but also the cable connection in a mechanical way.

Again about USB limit, when you set it and save this will be saved in the profile you use but if you are in one of predefined profile this cannot be changed … just driver switch to custom profile, if you select a user profile you can change how you want … always remember to press save.

Another tip … not connect slow and fast device on the same HUB.

Remember to manage in dragscript the action result, in this case if you manage the IF ERROR case you can send youreslf a signal about problem and restart the sequence waiting you look at it.

All the best
LO

Hi, Leo,

Thanks for the suggestions; I’ll try saving the settings.

When you say don’t connect slow and fast device on the same hub: can you clarify? I have a powered 7-port USB3 hub to which I connect: my two USB3 cameras, my mount (UBS2) and my focuser (USB2). My ZWO filter wheel is connected to one of the USB2 ports on the back of the ASI 1600 camera.

My laptop only has one USB-C port, so I have to connect the equipment via an additional hub. Are you suggesting I should have two separate powered hubs, one for the camera, and one for the mount/focuser?

I guess the next step would be to download a USB sniffer and collect some traffic logs. I’ll see if I can get that going tonight.

Thanks again,

  • Rajeev

Rajeev.
If you go into Devise Manager on your PC, look at all the USB devises. The Power Management should not allow the PC to close the devise.

Nigel

1 Like

Hi Nigel,

That’s a good suggestion - I’ll try that.

Thanks!

  • Rajeev

What Power Management Option are you using? Battery saver?

Rajeev, what is your total USB3 cable length between the 1600 and your PC? It’s imperative that it be under 3 meters.

Bill: I have the laptop plugged into the wall, and set to not sleep or turn display off, so don’t think that’s an issue. I did just turn off USB power saving, as Nigel suggested; will try that tonight.

Eric: I have a 9 foot (2.7 m) cable running from the laptop to the powered hub, which is mounted on the side of the OTA, and then short cables (no more than 1 meter each) from the hub to each of my devices.

  • Rajeev

If you have a mixed. Slow and fast device hub can have trouble , depend on hub and how is written the driver for the main board of your pc. Personally I removed usb hub and introduced a mini pc with multi ports. But before to be real drastic try to exclude all the process running for AP from antivirus and defender rules and open just the application you need. Also if you have great and fast pc practically the processes are at 32 bit, so memory space is limited. And for first check your cable connection … in in all position are mechanically right

i might tell you… i had serious problem with the pegasus’s ultimate powerbox. The first relase was made only with usb2 controller, so not that horsepower in there. it simply looks like cmos cameras doesn’t like to share USB3 port with other devices, a lot of downloading artifacts, broken images and so on.

Your computer has enough power to run deep sky astrophotography, still, that single usb port might be a problem. Or maybe, those chinese brands are great to spread technology, but falls short in terms of driver development… who knows…

Rajeev, I recently went through your USB traffic/camera error problem. I took a closer look at the total length of my USB3 cable length, which turned out to be about 4.5 meters; 50% longer than the specifications. I experimented and gradually trimmed down a bit at a time. I could not get a problem-free connection until I reached 3.2 meters. I’m now at 2.8 meters with no problems at all.

You’re now at about 3.7 meters, which is a length I could not get to work reliably. You’ll likely need to get your laptop closer and use a 2 meter cable to your hub.

We have another forum member that has gone through this, and solved it by shortening his cable run. I think you’ll be another that will be pleased by doing so.

Best,

Eric

1 Like

I tried again last night, following Nigel’s advice of turning off power saving on the USB ports, and also making sure to save the USB limit to 40 to my profile. Everything seemed to work fine, at least for 4 hours, when clouds rolled in and I had to pack up.

I’ll keep an eye out to see if I have the problem again. I may need to take Eric’s advice and either reduce my cable lengths or add a repeater cable.

Thanks everyone for your helpful suggestions,

  • Rajeev

I was getting camera download errors, but the root cause was actually a bad connection to my mount (serial cable in my case). I replaced the mount cable and this fixed the camera download problem