Guide parameters - once per session not per run


#1

Leo

As a newbie to Voyager, I’m using the sample “All-night Imaging” script as a template to plan my all night sessions: http://voyager.tourstar.net/files/Startup-to-Shutdown-Example.vos
Before moving onto the Sequence blocks Voyager calibrates its guiding parameters (in my case using PHD2) and then moves onto imaging. This is all well and good if I can successfully carry on and don’t need to change any of the parameters for the sequences. However, if I stop the DragScript and modify any of its parameters either because I am learning on the go or because conditions change, Voyager needs to carry out a full guiding calibration.
I know you are opposed to storing the guiding parameters from session to session but would it be possible for them to be stored from run to run? I mean, if I don’t close Voyager whilst I modify the DragScript, can Voyager not use the parameters acquired (and still present with PHD2) from the run I just aborted?
Thanks

Roberto


#2

Hi Roberto,

but you have mount connected also to PHD2 ?


#3

Problem with store guiding vector is (and is the reason why im reluctant to do) :

Voyager is an integrator … all must be work in the same way independent to guide control … this is also impossibile .

PHD2 at beginning doesn’t manage vector and now is better but again i cant load vector in just i need to trust user (isn’t a good way) and the mount must be connected (i’m not sure). DEC is not scaled if no mount connectd (correct me if im wrong)

Maxim handle this and i can add but only for Maxim.

Hard decision to give … i just talk about with Rowland.
Now i’m explained the reason … i’m open to all solution but … calibrate and guiding every time will remain because my experience say is better (cold, hot , unbalanced, VSF problem, extinction, wife humor and so)


#4

Yes, both mount and PHD2 remain connected. I just abort the DragScript to edit and restart. I tried restarting from further down in the Sequence blocks but when it gets to imaging it complains Guiding has not been set.

Roberto


#5

I also have to say that I am a bit spoilt with my mount. I have used MaxIM since v2.0 in the early 2000s. My mount since 6 years ago is an Astro-Physics mount (900GTO or 1100GTO). I have calibrated MaxIM twice in the last 6 years (my setup is in my backyard observatory) and have always had very good guiding. Roland Christen of AP recommends not changing the guiding parameters, particularly DEC compensation, for AP mounts so I don’t have that option ticked either.
I don’t want to use MaxIM or any additional software for acquisition (well PHD2 and CdC will have to do) but Voyager! :wink:

Roberto


#6

Hi Roberto,

LEO - you can’t read this because if I’m right, you may decide to change this to force calibration :slight_smile: :slight_smile: !

I think if you set things this way in the Sequence editor on the Guide/Dithering panel - with Calibrate Guide unchecked - it will just start guiding and taking exposures without bothering to Calibrate. At least I’m 90% sure that’s how it’s working for me!

Rowland


#7

Rowland

Thanks. That option is unchecked already in my sequences. That is why I don’t understand the reason for Voyager asking for another calibration if I have not disconnected my setup. I will check again tonight but I am almost certain all my sequences have that removed.

Roberto


#8

Hi Roberto,
I just read the log from two nights ago. Using the same script as you. I do Calibrate with a DragScript action at the start of the night.

I checked the log from the start of the second sequence for the night. It went through focus, precise pointing, and then starting guiding with PHD2 without a calibration. Here are my sequence guide panel settings:

image

And my guide Setup:

BTW I love being able to copy and paste an image to this Forum and have it upload! Very convenient.

Maybe there’s some difference in our PHD2 settings that causes Voyager to request another calibration??

Cheers,
Rowland


#9

Rowland
Thanks again! There must be a difference in our settings. I will check against your screenshots and revert.

Roberto


#10

Ok Roberto. about PHD2 Just tell you and to all about guide and meridian. Voyager calibrate guide at sequence start and at meridian flip … in this way user cannot do something wrong and all work fine.

If Voyager doesn’t calibrate for you at beginning and at flip something bad can happen:

  • Voyager use the guide calibration saved and calibration was done in the right side of meridian … result = OK

  • Voyager use the guide calibration saved and calibration was done in the opposite side of meridian … result = KO sequence aborted after some guide error if you dont check calibrate in sequence

  • PHD2 is not connected to mount or connection is lost … at change of meridian nothing happen , voyager doesn’t have flag checked for calibrate result is abort of sequence for guide error. Solution is to force Voyager to flip data in automatic mode to PHD2 (but work if mount is not connected ?)

Like you see a lot of thing is out of control of Voyager and in the user hands and PHD2 hands … not good for automation … just good for who want to go FAST (no good in AP)

Guiding calibration should be for session in Voyager … i can check if not i can change. But also in this case what happen if you start a sequence after meridian using calibration done before and you mount is not connected to PHD2 ?

There’s a lot of things to be sure … helping one means create trouble for lot in some case. So many people coming from other Automation App for guiding and meridian problem … this App think in terms of Fast and fast solution is not always the best solution.

My opinion is to leave the actual way to do of Voyager and try to add store vector guide mode but like option with a big disclaimer. Actually if im not wrong there’s no mode to force vector in PHD2 just ask to flip or not. If developer allow to force vector voyager can manage all like maxim can do all the thing coming back simple. i’m waiting to this change in PHD2 since today … now i try to find other way.


#11

Leo

Understood (mostly :laughing:) and I agree with your approach (better safe than sorry). I thought PHD2 recorded the meridian side on which it was calibrated and then adjusted after flip?
Last night, I imaged for the whole night for the first time with Voyager :muscle: (from 8PM to 5:30AM) using a single calibration and my mount had to flip. NO additional calibration was necessary after meridian flip occurred.
Roberto


#12

If is connected is ok … the problem is (lke i wrote) if is not connected.
Not all mount allow more than one ascom connection … and using hub poth sometime is not connection guarranty.

I have an AP mount (Mach1) and when i setting up (i dontthave an observatory) if i dont redo calibration things are not good … you must think that Voyager have few user for sure but not all work in the same way.

I want to maintain Voyager in a way that no mistake can be done by one.

Just a phylosophy

Anyway if i fix for session guiding your ask is solved !

PS sorry for my english … i hope you don’t think that my developer or Ap quality is the same or based onmy english level


#13

Ok I need to check my settings versus Rowland’s.
Just to reiterate myself, my mount remains connected. The AP ASCOM driver handles all the applications which connect to the mount (APPC, PHD2, etc) without issues.
If you are saying that as long as the mount is connected and PHD is calibrated I should not lose the calibration even after restarting a DragScript, then I must be doing something wrong somewhere else.

Roberto


#14

Ok i’ll check where i lost the calibration info … if you have log about this you can help me to short the fix time.


#15

As much as I want “speed” - I don’t want speed that hurts image quality.

And I don’t way Leo to spend most of his time on support issues caused by mis-configuration of other software. I’ve seen this happen with other imaging software and I know it takes away from development time.

So I respect Leo’s choices to make Voyager as “fool-proof” as possible. Better images, fewer support issues. These are good for both new and old users.

But I will probably continue to ask for “silly” things :slight_smile: … and we are lucky that Leo is creative and I know he will think about ways to provide those things without compromising quality.

Cheers,
Rowland


#16

:slight_smile: … this is an italian embedded quality … to be creative …


#17

I must investigate in abort command … probably reset the calibration status.


#18

Hands up! I MUST HAVE BEEN AT FAULT
I tried to repeat the same problem I outlined above using the current version of Voyager (2.1.0) and couldn’t. When I did encounter it I was using one of the pre-releases (probably e).
In any case I ran my script, calibrated guiding and started imaging my first target then:

1 - Aborted and restarted from beginning of sequence - and guiding parameters previously acquired remained and guiding process resumed

2 - Aborted (clicking twice) - and same good result as above

3 - Halted all processes - and after restarting from sequence same good result as above

4 - Halted and parked - and after unparking and restarting from sequence same good result

So I must have been doing something wrong in my previous run - as I am sure I did not disconnect the mount.
Rowland, my settings were the same as yours - thank you.

Another full night of imaging (testing really since Moon was pretty bright) running from 23PM to 5:30AM; fully unattended.

Thank you Leo! :+1:

Roberto


#19

Great , I’m happy all gone ok.

All the best
Leo