Robofocus config question

I am using Robofocus in my sequence and drag script. I wan’t to make sure the focuser returns to correct position for plate solves on the L filter after focusing HA. My L filter is 2mm and the HA is 3mm so these are not parafocal.

Current settings
Drag script goes approximate focus position for the L filter to start the night.
Drag script robofocus on L filter.
Drag tests plate solve , IF ok go to sequence 1

Drag script enters sequence 1.
Sequence 1 is set to image by filter group and use actual filters with robofocus
Right now it looks like the sequence will focus my first filter in the sequence which is HA.
After doing this it will next plate solve with L again.
Looks it is not going back to the L position achieved prior to entry into the sequence.

I had MaxIM handle the offset between filters previously. I am trying to use only Voyager and not use an additional MaxIM focuser connection.

Thanks
Max

Dear Max , voyager doesn’t have filter offset. Plate solve work also if you are out of focus usually. Anyway you can override filter for plate solving in sequence.

All the best
LO

Plate solving does not require critical focus, and 1mm filter difference will not be enough to cause failure in solving. The optical difference there is 0.3mm. While you would want perfect focus for light frames, that is not enough to cause solving to fail.

Fails 90% of the time …
It very out of focus at f3

Surprised that Voyager can not return to last known focus Position for the L filter

We should at least be to able to use specific a focuser index position for L

I agree it does not have be perfect for plate solve

Max

Change the plate solve to R filter.

Hi Max,
what you ask is exactly offset.

Sorry but Voyager at now doesn’t manage offset. Voyager do the focus with the filter asked and dont touch focuser until next focus or if you manually move. If you work at F3 just use HA filter for plate solve , create a profile cloning the actual and change setting to have more time and bin in plate solve setting or leave the current profile and in sequence setting choose to plate solve bypass the general setting and use actual filter.

All the best
LO

1 Like

Hi Max,

Couple of things you can try:

  • Bin the L filter to 4x4 or higher
  • Use another filter instead of L for plate solving (R,G,B)
  • If you are running your Camera with MaximDL or TheSkyX you can set up filter offsets there.

In my experience not using offsets is more robust and produces better results, so it is worth the shot to try to configure your system to remove the offset dependency.

Cheers,

José

I have checked the box in Sequence to overide the default filter. However, this does not appear to execute on my systems. It always returns to the L filter for Plate solve.

NB filters will solve in 5 secs alway for me, it is a big chip.

I now have to connect MaxIM DL focuser which controls the offset. Otherwise, it fails. I am trying to simplify the setup. I prefer not to uses offsets

I will try 4x. Right now the out of focus doughnuts are not seen as stars

Hi Max,

the flag check mean to use the actual filter, if actual filter is L Voyager use L to plate solve. So if you want to be sure that use a deterministic filter just clone profile and choose a different filter for plate solving pushing on binning and time. This solve all problem.

All the best
LO

The default Plate Solve filter is L in setup-profile. I have tested the check flag “use actual filter” in sequence.

Sequence focuses in Ha ( 3mm filter) then returns to default L filter (2mm filter) when I use this flag.

I think the intended red text flag is so Voyager will use the current filter that was focused by sequence?
It does not do this for me.

Thanks

Max

It switched to the L filter for plate solving after focus finished and it slewed back is my guess.

Yes, it switched back to L. That was the action I was hoping to overide.

Max

Max

When it starts the sequence, it will switch back to the filter you focused with AND to the position of the focuser in which best focused was achieved.
It works all the time for me.
Roberto

This flag was born for photometric filters.
So i will do a change in sequence configuration , i’ll add fields to override completly the plate solve filter data.
I’ll do this today and pubblish a daily build Max.

I hope this can help you.
LO

I look forward to testing this.
Thanks Leo .

Please let me know if this solve your problem, i need to go out with new official release of Voyager and i would include this change.

Thank you so much.

All the best
LO

1 Like