Windows user account control issue

I have labelled this one as a beginners question. I have had Voyager installed for a while but only recently decided to buy a license and move to using it after running it in demo mode for a while.

I downloaded and installed release 2.2.4 before importing the license file. I am running in to a problem where Windows user account control is prompting me with the “Dow you want to allow this app to make changes” message every time I open Voyager, although I log in to the PC with an administrator account and I have gone in to the compatibility settings menu for the Voyager .exe file and checked the “run as administrator” box. This is under Windows 10 pro, build 1903.

I have spent the morning googling but have not got any closer to a resolution, has anyone else encountered and resolved this? I am hoping to set up Voyager to start on booting the PC so once i have things set up properly I can set it running via the web dashboard.

Dear Blue,

Running Voyager as an administrator allows Voyager to communicate with other programs but it also gives Voyager permission to make changes to your registry and file system which prompts the warning from Windows.

You have two options that I am aware of:

  1. Start Voyager as an elevated task (https://winaero.com/blog/create-elevated-shortcut-to-skip-uac-prompt-in-windows-10/)

  2. change your User Account Control Settings to “Never notify” (Control Panel>User Accounts>Change User Account Control Settings. However, this will also eliminate all warnings from any program that is making changes to your computer (generally not an issue unless you install lots of software from unknown sources).

Steve

1 Like

Thank you! Via task scheduler was the way. I had done something similar a long time ago and had completely forgotten how to get to it. I have mine set via the scheduler to start Voyager elevated, 30 seconds after log in so if I have imaging plans already set up I should be able to just start up the machine (Headless) on my mount and get the session going via the web dashboard.

If I want to do something else on the machine I can close down Voyager manually.

I spoke too soon.

While it is a PC dedicated to astro work I am not keen to disable the UAC system completely, it is connected to the net. Creating an elevated task to start Voyager works in avoiding the UAC popup but when started that way, Voyager wont connect to the camera (ZWO ASI294 using the Voyager native driver integration) the mount via EQMOD (EQMOD starts but won’t connect to the mount) or to Platesolve 2. All of the above work if I start Voyager normally and answer yes to the UAC prompt.

I think I will look at automating the startup later when I have time to trawl logs files and see if I can work out why the connection issues occur. It will be convenient to be able to just power on the PC and go but it is working aside from that.

I got enough clear sky last night to run the VCurve first light wizard, get the focuser up and running and build a basic sequence to get some first light images.

Hi Paul,

i hope this can help you:

This if its a dedicated PC to astronomy.

All the best
LO

Thanks, I will have a look through those though I am not sure I want to disable it altogether, the machine is almost 100% dedicated to running the mount and image capture but not quite.

For the moment I can continue with simply giving the OK to the UAC prompt on start up. My previous software had to be manually started anyway, so it is not a disadvantage as such.

Sorry to hear that an elevated task didn’t solve your problem! I agree that turning off UAC is sort of a “last resort” option, even for a dedicated PC.

Quick question: did you use Task Scheduler to create the elevated shortcut or did you use Winaero? I forgot to mention you should read all the way to the bottom of the article in the link which references a very handy Windows utility called Winaero. As the article mentions, using task scheduler to create the elevated shortcut results in the program running at lower-than-normal priority while using Winaero runs the program at normal priority.

I have been using an elevated shortcut created by Winaero and everything connects and works just fine. However, I am using TSX to control my equipment rather than directly through Voyager. So, you might want to give Winaero a try and see if it makes a difference.

All the best,

Steve

I had created the task manually via task scheduler, I will download and try Winaero tonight and see if it gives a different result. I don’t have clear sky in the weather forecast for days yet so I have time to play.

It will be interesting to know if Winaero makes a different. Note that the “Elevated Shortcut” tool in Winaero has moved from “Tools” to “Shortcuts” in the latest version.

1 Like

Awesome, whatever the difference is the Winaero generated elevated shortcut works, Voyager starts without a UAC prompt and connects to all the gear. I was also able to copy the shortcut to the user “start” folder and Voyager now launches on login (And the machine is set to log in on boot)

Basically now with a little organisation in the front end to set up sequences and once I get across them, drag scripts I could pre-build a star party worth of targets and simply set up my gear (Which includes a wireless router) and then do everything else from a tablet, as the web dashboard will be available about a minute after power on.

2 Likes

That’s great news! It must have something to do with the Winaero-generated shortcut running Voyager at a higher priority than the shortcut generated by Task Scheduler. Plus, you get the bonus of a really great windows utility!

Clear skies!

Great news

All the best
LO