Alternatives for DSLR (ASCOM driver for DSLR?)


#1

Having my QHY163M on repair I got my old Canon 40D from the drawer and put it on the workbench and then on the scope.
Actually Voyager does manage DSLR by means of MaximDL (which I do not own and I do not want to buy just for this task) only.
Now I see on the net there is an open project sharing a DLSR ASCOM driver (see for example https://www.cloudynights.com/topic/625568-ascomdslr-ascom-driver-for-dslr-camers-canon-nikon/).
I’ve tried it but it does not work with Voyager (it gets stuck when trying to get a shot) while it is working in other SW like Sharpcap for example.
It would be nice to have it available in Voyager as well.
What do you think about?


#2

Sorry Fukinagashi but ASCOM is equal for all … i cannot answer to your question.
Try to ask question to the driver developer … probably they can solve looking at ascom log.

For alternative i have the client code for BYE … very nice app. Probably i import this like camera control.
I dont want to wrote driver for Canon or Nikon for now. There’s to much competitor.

All the best
LO


#3

Where is the installer ? I cant found …

All the best
LO


#4

Leonardo,
here you can find the installer:

(see DSLR.Camera Setup.exe)

I actually use BYE to control my DSLR: is there the possibility (in case as beta tester) to try the BYE support for Voyager?


#5

Thanks,

sure … BYE or ASCOM is not fast as Maxim oTSX because they doesn’t use ROI or memory data but Voyager need to load from file on disk and simulate ROI … this mean some extra time on running.

When i’ll start development i’ll write here.
When i go back in Alps i test the ASCOM DSLR driver.

All the best
LO


#6

I’ve tested the ASCOM driver with my Canon 6D and Canon 450D.

BYE version is ok , doesn’t support binning but support ROI. for 1 shot of 1s take 15s of time (with on camera save file option in BYE) … i don’t investigate where is the waste of time but voyager need 1s to save file, download ready is signal to voyager 14s after real finish in BYE.

ASCOM version doesn’t work … stop at exposure with error (camera status become not connected and after busy). I’ve tested it also with Maxim that hang up in exposing status without exit and sharpcap with the same result. My result is this driver doesn’t manage in the right wait the camera status for wait i understand, probably is transition status or timing.

I think to creare a client for BYE and try to send a mail to the developer to understand if possible to fix it.

All the best
LO


#7

#8

If you use this ASCOM Driver and BYE you can use Voyager
I repeat because i’m not sure to have explained well, this must solve your initial request.

All the best
LO


#9

Leonardo,
not sure to understand well. Are you talking about the ASCOM.DSLR driver or what?
Voyager is not listing the BYE option in the list at the moment.
If I choose “ASCOM camera driver for DSLR” and try to set BackyardEOS the driver shows me the error:

Driver setup method failed: “ASCOM.DSLR.Camera” Camera not connected<


#10

No i tell you to use ASCOM.DSLR and choose BYE, set “image on camera” option in BYE and choose the right port. For me working good in Voyager. Obvius with camera conencted to PC. If you use ASCOM DSLR direct and you obtained the error you must restart PC to be able to use BYE variant.

Try to download the last version of ASCOM DSLR driver.


#11

I’ve downloaded again the ASCOM driver but it seems to be again version 0.5.56…
I’ve set “image in camera” in Quality setting in BYE, TCP server is on an port is correct.
But again when I load the ASCOM.DSLR from Voyager same result: “Driver setup method failed: “ASCOM.DSLR.Camera” Camera not connected”.


#12

Nothing to say about … is not really stable. In my pc work fine with 6D and 450D.
Have you the camera connected or doesn’t work also for setting up driver ?


#13

The camera is connected.
When try to load the driver in Voyager it opens BYE form for connecting the camera model (the camera connects correctly in BYE) then thinks a lot then the error.
When you say set “image on camera” option in BYE you mean set Quality=“In-camera” in BYE settings?


#14

yes, quality setting.
i cant help on thtat , wait for developer answer.