Autofocus issues

I have been using the Demo for several nights. All has been going well until I started using autofocus. I am using the standard default settings which I read takes care of 99% of situations. I attempted to upload a text log but could not.

I am using a Pegasus focus motor on a Moonlite SCT focuser. All seems to go well with autofocus but the program wants to go past my limit of 26000. The log reads it cannot, then goes to my middle count of 13400. At that point the horn goes off and I am given an error message.

I have read a lot about Voyager and its reliability and use. All good I might add. I am sure this is me and not the software.

Help would be appreciated.

Thanks, Johnny

Welcome Johnny!

You’ll get better help after Leo (owner/author) wakes up, but chime in for curiousity:

  • Are you using Robofire as your focusing method?
  • Have you (start from somewhat roughly focused; as long as you can see stars it’s OK) run a “First Light Wizard” in SetupForm → Autofocus tab?
    • If yes, did it succeed?
    • If not, and that’s where you ran into hitting the limit issue, you CAN perhaps change the “VCurve limit” in Robofire Configuration → VCurve Mode, so it scan less of the range during the first light wizard.
      • If that’s indeed the problem but this does not solve your issue, it sounds like your in-focus position is very/too close to your focuser travel limit…

Some thoughts.
Yizhou

Robofire, yes.

Roughly focused, yes. Actually fairly close. I’m using a Meade lx200, focusing with main mirror first then using a Moonlite sct focuser for fine focus.

I’ve tried First Light wizard several times without success. The log shows the software wants to go to 29000 but my focus tube has a maximum number of 26000. The software moves back to about 13000, then the horn goes off with an error message.

When focusing with the main mirror the Moonlite is set at 13000 and doesn’t move. My limit settings for the program are 0 to 26000.

I’ve double checked to make sure there’s no slippage regarding the focuser.

Thanks for your response. I’ve read a lot of very positive comments about Voyager, so I know the answer lies in my settings.

Hi Johnny,

how did you set ‘OUT Limit’ and ‘IN Limit’ in Setup/AutoFocus/RoboFire Configuration Center/Focuser settings in Voyager?

Vitali

When you are roughly focused, what’s the focuser’s position?

The way First Light Wizard works, per my understanding, is it starts from your current position X, and move by 1,2,4,8, …, 2^n steps in one certain direction step-by-step, until it hits the “VCurve limit”; By then it knows roughly how “wide” is your entire V-curve, so it flips to the other side, and map out the entire V-curve. So in theory it shouldn’t move large from your rough-focus position to out-of-limit position, unless your in-focus position is already very close to 26000…

A log would help…

Thanks to all for help.

@Johnny_Scarborough … send the log file zipped to the support email. voyagerastro@gmail.com . Best also a screenshot of realized partial initial vcurve.

Probably, like Yizhou wrote, you must lower the HFD ParametersVCurve Limit to work inside the limits:
https://wiki.starkeeper.it/index.php/AutoFocus_Setup#VCurve_Mode_Tab

All the best
Leonardo

The IN limit I just left at 0. The OUT limit I changed from something like 65000 to 26000, which is my Moonlite sct focuser travel limit.

Thanks, Johnny

Thanks again to all. I have sent an image of the partial V curve as well as a log to the support forum email.

I took the advice given and changed the HFD Parameters. Started with 3, 6, 12. Didn’t work.
Changed to 6, 12, 24. Autofocus worked. A nice symmetrical V curve.

Thanks for the help, Johnny

Hi Johnny,

3,6,12 is not a good choice because the lower limit in your case cannot go under 9 from the graph. under 9 your vcurve entering in non linear place and this is absolutely not good. Generally the values are to low and work in not linear place of vcurve.

6,12,24 again 6 is to low.

Best for your graph (I received it by email) is 9,15,28

Problem was in IN direction your limit do not allow Voyager to reach the HFD of 40 and stop to 35. In OUT no problem about.

All the best
Leonardo Orazi