Cartes Du Ciel won't launch

When I click on Connect in the startup section, it will connect to Cartes Du Ciel correctly if Cartes Du Ciel is already running. But I cannot get it to launch Cartes Du Ciel. I get an error that says:

‘No connection could be made because the target machine actively refused it’

I have the checkbox clicked in Voyager to “Try start exe on connect”. And I have the server in Cartes Du Ciel setup correctly because it connect if it’s running.

Is there something else I need to do to get the app to launch during connection?


Dan, to me it seems an issue with W10 Defender, respectively the firewall. Make sure to have Carte du Ciel as a “trusted and authorized” app. Can you check and revert ?

Thanks for the suggestion. I didn’t see anything in Windows Defender firewall that refered to “trusted and authorized” app. I went to:

Start > Settings > Update & Security > Windows Security > Firewall & Network Protection.

The firewall is “on” and I clicked on “Allow an app through the firewall”. I added Cartes Du Ciel to the list and clicked the checkboxes to allow on a public and private network. I verified that Voyager was also set the same.

I still get the same error message.

My bad, you’re right - there is nothing like “trusted app”… What I meant was rather add manually in Defender Carte du ciel / Voyager. Try this (if not already tried)

Select Start > then open Settings > Under Privacy & security > select Virus & threat protection.

Under **Virus & threat protection settings > select Manage settings, and then under Exclusions, select Add or remove exclusions.

Then Add Voyager / Carte du ciel, etc. FYI, that’s exactly what I did quite a while ago. Of course, you need to decide which software you can trust and therefore want to “exclude” from analysis.

I use MalwareBytes instead of Windows’ virus protection. So I have Windows virus protection turned off and there is no Manage Setting button.

But I did go into MalwareBytes and make sure that Cartes Du Ciel and Voyager are both on the “allow” list. In addition, I tried turning off ALL virus protection, including MalwareBytes, and I still have the same problem.

Do the CdC settings match Voyager? Mine look like the attached and works fine

Yep. I have the exact same setting as you show. And they agree with the settings in Voyager. The connection works fine if Cartes Du Ciel is already running. But if it is not running, connecting in Voyager will not launch it.

Hi Dan, Did you find a solution?
I have the same problem. :frowning:

Using cartes du ciel its really simple and connection is only TCP/IP method, so probably you have some user misconfiguration.

This is the kind of things to ask support about.

All the best

I just switched to using Stellarium instead. I like it a little better anyway. If I really wanted to use Cartes Du Ciel, I would pursue it with Leo via tech support as he suggested.

I would point out that there are problems like this if you start CdC from one user and then ask Voyager to start an instance of CdC as another user.
E.g if you are using Voyager as admin and expect to re-use a running instance of CdC started as a different user.
It looks like a Defender/firewall issue but its not really, nor a problem with CdC. I think its a problem with two identities trying to start another connection on the same port. Might indicate Windows isn’t too clever about handling this .