CDC 'Start on Connect' error

Hi Leo,

Still learning more about Voyager, but I’m getting there!

I’m unable to get CDC to load up when Voyager ‘connects’ to equipment unless CDC has already been started separately before attempting to ‘connect’. I’ve set the flag ‘Try Start Exe On Connect’ on the setup form, which I thought should tell CDC to start automatically if it wasn’t started previously, but the same error occurs whether that flag is set or not. If I open CDC before ‘connecting’ within Voyager, then the connection works fine every time.

When this happens I get the error: “Planetarium Connection Error = [ERROR CODE = CONNECTION_ERROR] : No connection could be made because the target machine actively refused it”

The IP ( and port number (3292) are the same in both Voyager and CDC and I’ve set full permissions to both applications …

Any thoughts what might be causing this? Or have I misunderstood how this is supposed to work?!

Many thanks,


I also see this behaviour on a laptop with a Trial licence (same error), but the demo version on a pc, it opens CDC no problem.

It’s likely a Windows permissions thing. As far as I can tell, both Voyager setups are the same, so I also need to understand this.

Hi Jonk,

Thanks for your input - that’s interesting, I’m currently using demo version on my laptop and have this problem! Was waiting until I’d fully got my head around using Voyager before progressing to trial version …

Laptop’s fairly new, i7-8550 chip, 16GB ram, SSD hard drive (>50GB free space) so should be more than man enough I would have thought. However, could this be an usual laptop thing in that case?

I’ve just checked again to make sure and both Voyager and CDC have full Windows permissions and they definitely do (as do both of the respective directories they reside in as well).

Anyone else seen this happen and have any advice to resolve?

Many thanks,


I’ve just had a look to see if there are any differences between 1 CdC installation and the other, and the first thing I’ve noticed is the file path differs between PCs:

Left hand image is PC with demo mode, that connects (C:\Program Files\Ciel), the right hand image is a laptop that refuses the connection (C:\Program Files\Cartes du Ciel).

When Voyager looks for the .exe file, is it looking only in C:\Program Files\Ciel? Meaning if the installation is in any other location, it won’t find it?

Leo - if this is the case, maybe an option to point Voyager to the .exe file in the planetarium setup tab is needed?

IF this is the issue here?

Well, this backs up my thoughts…I’ve changed the installation directory of CdC from C:\Program Files\Cartes du Ciel to C:\Program Files\Ciel, restarted the laptop and it now connects ok.

Hi Jonk,

You’re a star Sir, well done - very well investigated and deduced, that’s the solution indeed!

For me, Voyager folder is actually in C:\Programme Files (x86) and my CDC was in a completely different directory, with a different folder name, anyway. So, I’ve moved complete CDC folder to Programme Files (x86), changed directory name to ‘Ciel’ - and that’s it, is now connects correctly to CDC on Voyager start up as expected!

I can’t confirm if this same anomaly might exist for any other planetarium programme as well, because the only other one I have is Stellarium which (at the moment) is not compatible with Voyager.

So - it seems it doesn’t matter whether Voyager and/or CDC folders are in ‘Programme Files’ or in 'Programme Files (x86), as long as they are BOTH located within that same directory.

Leo - Jonk’s suggestion for Voyager being able to select the planetarium’s .exe file location might be a serious consideration in that case (on the set up form?). Or, in the short term perhaps a small update to the Wiki and/or Manual to clarify this requirement?

Thanks again for sharing the solution Jonk - although this was a minor inconvenience it was starting to bug me!!

Onwards and upwards …