Connecting EQ6-R Pro

I have tried to connect [EQ6-R Pro — Sky-Watcher] mount using sky watcher driver. I have no luck. I have tried with EQmod cable (Hand controller port of the mount to USB port of the PC) and using direct USB cable between the mount and the PC. No connection port to select to link. (Please see the picture)


What could be the reason? What is the best way to connect this mount to Voyager? I am a beginner to Voyager, help will be appreciated. PS: All other equipment are connecting via ASCOM to voyager with no issues. Thanks.


I suggest to use EQMOD. If you dont find the serial ports in the list you must check the hardware and driver installation of your port looking also in the device manager of the OS. Fix installation until you will see regularly the COM port on the OS. For cable between hand controller and PC you must enable the serial communication from the hand controller in mount, but in anycase the com port is visible on PC hardware device list.

The window you show is about driver itself and not Voyager, this configuration is driver side.
Voyager use ASCOM for mount management so until you will not get working the ASCOM driver you will not be able to use it in Voyager.

All the best

Thank you. I got the ASCOM driver working with installing the EQMod module. Now my mount is working with Voyager.


Hi Leonard,

I have a situation I connect my mount with ASCOM successfully but when I connect via Voyager I get a comms error. What could be the issue.

Please see the attached picture (ASCOM left, Voyager Right).



If you are doing so, don’t connect the mount before connecting the setup in Voyager, let Voyager call the ASCOM driver and make the connection. AS well as that, within Voyager (Without the setup connected) pull up the mount ASCOM properties from the mount setup tab and check that all the settings match what you have calling EQMOD outside Voyager. iOptron driver in my case, I have not got EQMOD installed on the machine I am posting from.


Thanks, Blue, yes I did this way to demonstrate that is it connecting via ASCOM. I normally do exactly the same way you described. Only issue I am noticing is that EQMOD does not find the comms port (COM5), so I had to select it manually when configure. When I connect via Voyager, It says “Connect Error: Invalid Parameter” and display the following message.
** Limit 0
Activating Joystick…
EQ Modded Mount NOT found at COM5: 0

The only time I have had connection errors like that was when the driver was already running and a connection made to it before I connected via Voyager. As Leonardo will tell you, best practice is to let Voyager start all other required software and drivers. If you disconnect the setup in Voyager, and disconnect anything else making a mount connection (Such as PHD2 or a planetarium program) the EQMOD window should close.

When you have that error it might be worth having a look via the windows device manager and make sure that the EQMOD cable is being detected and you can see COM5.

Dear Sudath,
I have a NEQ6 PRO mount and use an EQ direct cable, I set the com port to 10, I see your com port field is blank. See my screenshot. Also I use EQMOD and you can see on the left hand side that I am connecting using com 10. I hope this helps you.

Best regards… Steve D.