Connection Error with TheSkyX

I recently switched to Voyager, and I must say, I am quite happy with my experience so far. This really seems like a well-designed application. I like how it lets you configure lots of detailed options, but the UI is tastefully done, so everything looks clean and organized. I also like the stream of log messages that let you see how things are progressing.

After learning it for a few days, I finally had it configured for my setup. I was using an ASI 183 camera, and got a couple of nights where I could start it off and get some sleep. Unfortunately, I started having some camera hardware issues yesterday (weird banding when the cooler is on). While I’m sorting that out, I thought I’d try using it tonight with my SBIG STF 8300 via TheSkyX. However, when I try to connect to TheSkyX, it fails to connect, with the following error:

Has anyone seen this before? Not sure if I have something misconfigured… I am able to separately run TheSkyX and connect to the camera.

Clear Skies,

  • Rajeev

Make sure you run SkyX as administrator at least once before connecting Voyager

Welcome Rajeev and Mike … thanks Mikefor answer:

TSX talk with other application using a TCP/IP server, to register it you need to start at least once as administrator also you need to leave checked forever the TCP Server listener like in image. You’ll found this under Tools menù.

All the best

Mike, Leo,

Thank you - that worked!

While I have your attention, one other issue I’m running into: I’m using an AP 1100 mount with APCC and the AP ASCOM driver. I start APCC in Administrator mode, and then bring up Voyager. The first time I do this everything is fine. If I then disconnect my equipment in Voyager, and then try to reconnect, I get the following error from Voyager:

The only way I can recover is by closing all the applications (including APCC), then restarting APCC in Administrator mode and then bringing up Voyager.

I’m wondering if something in my APCC settings is wrong. I have my observing site (my backyard) set up with Latitude, Longitude, Elevation etc.


  • Rajeev

AP Ascom driver if closed sometime doesn’t release the connection if used by multithreading system.
Happen also to me that have from 10 years an AP Mount. next time connect but have not access to communication with the mount, this what happen to you. You must kill the AP driver from taskmanager.

Do some search in forum about APCC, you’ll found some usefull info.
There are some users with APCC i’m sure they can help you @rockstarbill , some flag to set in APCC.
Also can be useful to leave undisposed the driver AP,check the flag in the image

Hi, Leo,

Thanks for the reply. No worries - it was only an issue when I was setting up my profiles and trying out things. The workaround is not too bad. I’ll look into that setting you suggested.

I see that you plan to eventually support disconnecting individual pieces of equipment; once that’s available, this will be even less of an issue (I hardly ever need to disconnect the mount).

Thanks again,

  • Rajeev

Thanks Rajeev but i remember someone solved with a setting in APCC but i cant find it


So … found

Oh, sorry for missing that. (I have been looking at the wiki, which is quite useful, but somehow overlooked this FAQ.)

Thanks again, Leo!

  • Rajeev

Let me know if solve

All the best

I get this error frequently when I disconnect equipment within Voyager but forget to disconnect equipment from other programs that may still be using ASCOM drivers. The main one for me has been PHD2. The error appears when I subsequently try to reconnect equipment within Voyager.

In the latest version of Voyager, Leo has added an option to send an equipment disconnect request to PHD2 when disconnecting equipment within Voyager.

Kind regards,