Does Voyager Support J2000 to JNow Conversion?


I have just downloaded the trial and am looking forward to testing the capabilities of Voyager, in particular the AutoFocus functionality.

Scanning the menus, it appears that Plate Solving uses J2000 co-ordinates, but my iOptron mount uses JNow. Does Voyager have a conversion routine from J2000 to JNow?

In my current setup, I use the tried and trusted AstroTortilla Plate Solving software and this has the option to choose the appropriate system. I looked at ASTAP as an alternative to AT, but this appears to support J2000 only.

Apologies if I have missed something obvious in the documentation, but I suspect that my hardware may be incompatible with the Voyager product?.

Many thanks and regards


It must be.
My mount (Mach1) uses JNOW as well and the mount works flawlessly under Voyager.
Here is the Voyager logs from a syncing command.

    2020/07/06 00:17:02 787 - INFO      - [OnTheFlyForm                 ] - [cmdSyncToSolved_Click                        ] - CMD >= Sync To Plate Solving Data
    2020/07/06 00:17:02 802 - INFO      - [OnTheFlyForm                 ] - [cmdSyncToSolved_Click                        ] - Sync to RA/DEC (J2000) =17 59 14,026 /49 22 18,11 
    2020/07/06 00:17:02 833 - INFO      - [OnTheFlyForm                 ] - [cmdSyncToSolved_Click                        ] - Conversion Sync to RA/DEC (JNow) =17 59 46.632 /49 22 22.20 
    2020/07/06 00:17:0

The log has this line “Conversion Sync to RA/DEC (JNow) =17 59 46.632 /49 22 22.20”.

Hi Donghun

Many thanks for your very fast reply! It appears from the logs that you posted, that Voyager operates in J2000 than converts to JNow before communicating with the mount.

That is most helpful and thanks once again for your prompt reply!

Best wishes

If you are new to Voyager, remember press sync button after you do a manual plate solving from the “on the fly window” to sync the solved coordinates with the mount if you are used to some other applications like SGPro.

Other automatic actions such as precision pointing and RoboStar focusing will issues sync commands as well as plate solving.

Thanks for that, Donghun, good to know because I shall initially be working from the ‘On the Fly’ window to get a feel for how it operates.

If only the clouds would clear!

Thanks again

All plate solving system return J2000 coords and doesn’t support any else epoch. This is the reason you dont find anything about in documentation. Target coords and other coords in Voyager are always specified if to use J2000 or JNow… usually is always J2000

Voyager check your mount coords system and do the conversion if necessary for your mount.
Usually all the mount using a JNow system and this have sense.

At now the only equipment not compatible with Voyager is the Baader focusers and this is not your case.

All the best

Many thanks for the explanation Leo, that has clarified it for me.

You are correct, I use PrimaLuceLab Sesto Senso focusers and will run Voyager from my Eagle 3S Controller after testing it on my laptop. Full Italian integration :slight_smile:

Best wishes