Dome Issue with SkyRoof ASCOM Driver

Hi All,
I am not sure if this is an issue with the ASCOM driver itself or how it is implemented in Voyager. But I thought I would ask here.

I am using SkyRoof from

Is anyone here using it successfully with Voyager?

Voyager will only connect to the driver when it is the only application doing so. If I have the SkyRoof application running and connected, voyager will give a “serial port connection error”. If I turn off SkyRoof, Voyager connects. I can connect simultaneously with MaximDL to SkyRoof. But if MaximDL is connected to the SkyRoof Hub driver, Voyager will not.

The ASCOM driver is a hub type driver so multiple applications should be able to connect to it. When I choose it in Voyager I see the SkyRoof Hub driver. I chose it but instead of saying it is already connected, it asks me for the com Port… It does not help if I choose the ASCOM connectionless option.

I am not sure if this is a problem with the ASCOM driver or the way it is called in Voyager… any suggestions?



If your driver accept only one connection (serial error show this) you can connect only one app. If you want connect more than one app you must use an ascom hub.

Voyager implement standard ascom. Your error about a serial mean you want to connect one serial from two application. This is not possible if you don’t have a driver with virtual port service or local server architecture.

All the best

Hi Leo,

The driver does accept more than one connection from other software. I can verify that. It will connect with MaximDL and other automation software simultaneously. But it will not do so with Voyager. The driver does have a hub service running SkyRoof Hub Driver Server.exe so it does seem to be operating as you require.

But I can get a serial port error when I use the ASCOM Device Connection Tester when I choose the Skyroof Hub. So it seems to be the driver…but I still wonder why some applications can work with the hub.

I am follow up with the developer to see if he can help.


You must start voyager for first and leave it open all. Serial error mean connection direct to the driver not to the hub. Ascom interface is equal for all. Just tell you Voyager start like admin, you must remember this.

If you think is a bug or you need support please refer to support mail in license.

All the best

Thanks. I am running Voyager as Administrator.
I am able to get the error in the ASCOM Device tester so I am going to follow up with the developer of SkyRoof first. I will follow up with a bug report if needed.

Thank you.

Hello Russ,
Did you ever get this issue resolved?
I was thinking of adding a skyroof controller to my ror observatory to run via Voyager.

thank you

Yes the solution is you have to run the skyroof application as administratior. But to do that successfully required setting a batch file to execute the skyroof app. And set the batch file to run as admin. The reason is the skyroof developer used a type of install that did not allow running as admin. But by having a batch file fire it off as admin was a work around.


1 Like

Thank you Russ, it is appreciated.