Dome Not Slaved To Telescope


I see there is a selection to “Dome - Slave on Sequence Start” uner the Dome tab in Setup Form. I’m assuming that the dome will rotate to align with the scope/shutter on sequence start.

But what if I just want to mess around with things and point to different parts of the sky (maybe to do a sky model) and want the scope Dome to follow the scopes movement - is it possible to do this? Not to bring SGP into the discussion but SGP does have a check box for this - is this possible in Voyager?



As I am playing around here, I see in the Monitor window the following message:

Dome Slave Manager: Slave is Locked to OFF from Voyager User

How to I get this to be unlocked? Is that something Leo controls or do I have to get the ASCOM developer of the Nexdome ASCOM driver to somehow allow Voyager control over this?

I use drag script most of the time. I add an explicit slave or unslave command during the script.

I am not sure when using On-the-Fly Area for a single sequence if it automatically slaves at start.
You will have to test it.


Voyager does not have it’s own internal slave facility.
Are you using an ASCOM compatible dome ? Then you can use an ASCOM hub such as POTH or ASCOM dome to set up for slaving.

**** You will need to make sure that both the mount and dome are configured in the hub first. Test the hub’s connection and dome geometry parameters for slaving. Then disconnect and close the hub.
In Voyager’s setup choose the same ASCOM hub for both mount and dome then connect voyager.

Voyager should launch the hub and connect to both dome and mount properly.
The hub applications have a slave check box ( voyager lacks and manual command in the box you pictured )

TheSky has nice slave facility called automadome if you happen to own a Paramount / TheSky suit already. It too expensive otherwise IMO. The set up procedure is different.

Finally, I choose the same hub as the mount for PHD guiding. If you connect direct to the mount rather than the same hub, it may launch another instance.

Try ASCOM dome to test this. It is part of the ASCOM package already

Go to C:\Program Files (X86)\Common Files\ASCOM\ASCOMDome.exe

Drag a short cut to the desktop and set it up.


Hey Thanks…I think I understand. Basically just use the ASCOM POTH or similar to control the scope/dome and all should be good. Its a Nexdome and there is an ASCOM driver which works well. Will sort it out.


Just remember to connect Voyager to the hub for both mount and dome. If you connect only one you might see a problem.
Voyager needs info from POTH for both devices to slave properly.
I found it liked to take pictures while to dome was still moving etc


Hi GeneralT001,

if you presso button S0 you slaved off the Dome, if you press S1 you Slaved on your Dome
Voyager doesn’t maange geometry and sync of your dome, or your dome have this inside their driver like most of this kind of control or you must use external pubblic way to do this. POTH or ASCOM Dome support are some example, this mean an extra configuration to do outside and inside Voyager. We have do this for NexDome brand for some users.

Flag “Dome - Slave on Sequence Start" mean when you start a sequence Voyager Slave the dome for you if the dome have internal (Hardware or Software) way to do this.

For message “Slave is Locked to OFF from Voyager User”, Voyager report it when:

  • when Slave is not supported/possible in the Dome driver
  • when Slave is set OFF by user

Some news about NexDome brand interactions with Voyager will be released in the next weeks.

All the best

Just to make sure I have this right:

I am using the ASCOM Device Hub - which I have setup for the mount and dome:

I have set up Voyager to use this for the mount and dome:

Is this correct?

Looking at your images of settings:

  • flag on the “Use the best performance after finished pointing retries”
  • flag on “Dome - Slave on sequence start”

For ASCOM Device HUB I cant help.

All the best

Thanks Leo :). Can’t wait to try it out under some starry skies!!

Looks good to me
If your using a scope for guiding rather than relays in PHD , connect the hub rather the scope driver directly.
Otherwise it might want to launch another instance of PHD.

Glad to see you are using the ASCOM device hub , I was the primary beta tester. The author is a local friend.
Let me know if you see any problems
It is still quite new


Hi Max,

Wow…thats cool about being the primary BETA tester!! One thing I have noticed is that sometimes the display panel just disappears after I’ve opened another program (such as Voyager)? Its still running but cannot get to the panel anymore? Even if I try opening another instance of it I can’t and get a small panel advising that it is already running? Then the only thing I can do is kill it in Task manager and relaunch?

Also, as an aside - there is always a lag (5 - 10 sec?) between when you slew the scope somewhere and the dome finally moves. Is there anyway to have the scope and dome move closer together?

Once it is set up disconnect the scope and dome
Then close the hub interface

Voyager should connect all items properly now

However, it won’t show the hub interface on the

Voyagers connections should show ASCOM device hub for scope and dome in green text

You should be able slave and command the dome with Voyager now

If you are configured correctly
the dome should slew within a second or two after telescope

Maybe I need to a doc with screen shots?

If want you want to keep the hub interface on the desktop while Voyager runs try POTH orASCOMDome
They will launch the hub, interface to desktop when Voyager connects

Hi Max,

No I don’t need to see the interface if Voyager will connect to it now that it is set up. Will try that out tonight. If I see any issues I will post back…but I expect smooth sailing :slight_smile: Thanks!!

I have the ASCOM Device Hub setup properly (I believe for the AP mount and Nexdome Dome).

Now, if I have the ASCOM Device Hub closed and run Voyager then I get the following error:

But if I open up the ASCOM Device Hub first and connect the mount/dome and then launch Voyager all seems to load fine? I think you said I could leave the ASCOM Device Hub closed once it is set up and Voyager would open it and load the necessary drivers? Did I read that wrong?

The Hub Interface you showed earlier should shows NO Data. Something is not connecting with the AP driver.
Does it work with POTH ?


Should look like this for any hub

Yes, you are correct. If I do try to connect just with Voyager then there is no data on the Hub. Of course when I connect the scope/dome direct to the Hub then it reads the data sent from the mount.

POTH does seem to work properly. If I run Voyager - without POTH open it will connect properly and the only thing I have to do is check the “slave” button in POTH.