Dragscript errors with multiple ZWO cameras


I ran into some unexpected errors while trying to run a dragscript to collect dark frames for one of my ZWO cameras. My setup is that I have 3 ASI cameras (ASI 1600 on the main scope, ASI 178 on my guidescope, and an ASI 183 on camera lens). I did an imaging session with the ASI 1600 and the 178 successfully. Then I disconnected everything and switched to a profile that has only the ASI 183. I tried running a dragscript to collect dark frames, but the expose commands failed with errors:

05:55:04 578 - Run Action => Expose: Filter [7] Dark - 0 [s] - Bin 1 - Full Frame - Bias - NB_Bias - [CMOS Gain=111 Offset=10]
05:55:04 602 - Camera Expose : D:\astro\ASI183\Bias111\NB_Bias_BIAS_ND_20191008_055504_061_U.FIT
05:55:04 651 - Action Time [ATOMIC_CAMERA_SHOT] => 0 [m] 0 [s] 
05:55:04 664 - Action Time Mobile Mean [ATOMIC_CAMERA_SHOT] => 0 [m] 0 [s] 
05:55:04 676 - ERROR (FINISHED) Camera Expose  : Object reference not set to an instance of an object.

I then used the On-The-Fly panel to take a single camera shot; it succeeded (and I could confirm from the image size that it was taken with the ASI 183).

I’ve tried shutting Voyager down and then reconnecting to the ASI 183 profile, but still get the same errors. Any idea what the issue may be?

Thanks, and Clear Skies,

  • Rajeev

Hello Rajeev,

i need to fix the error description in this case i leave it too generic.
Are you sure the filter index 7 exists in the Voyager setting ?

For more info i need log file.

Let me know.