DragScript - GNS

I am testing the GNS software with Voyager using DragScript. This is the script I am using for the test:

External Script: C:\update.vbs “Event 1” 10
Wait Time: 00:00:05 Interval
External Script: C:\update.vbs “Event 2” 15

When I run the DragScript the Windows GNS app opens up and correctly shows the event messages and timers. It then times out 15 seconds after Event 2.
On my Tablet I am testing with the NAP version of GNS Android App. It connects to the windows app and it also shows Event 1 and begins a 10 second countdown.
The problem: when Voyager updates the windows app, 5 seconds after Event 1, the windows app does not update the Android app. So when the Event 1 timer times out at 10 seconds I get a timeout alert on the tablet.
In other words, the tablet sees the first event but does not get refreshed with the second event.
Is there something I need to do in the Voyager external script call from DragScript to reset the tablet? Or, is this what the NAP version of the Android app does, but not the paid version?

Hi Craig,

Wouldn’t it be better to apply also in the GNS forum? It doesn’t seem like a Voyager-related issue.


I use the IOS version of GNS and don’t have this problem. But it sounds like a timing interaction condition that can probably be fixed with different settings. the GNS app has a Polling Period setting on the Configuration page. You can try shortening that to 5 seconds. Also, in your external script you can try increasing the timeout value for event 1.

Keep in mind that GNS is just there to notify you when something goes horribly wrong. If something takes a few seconds longer than expected, that should not be an issue. So you should be able to make your timeout values significantly larger than you think you’ll need to handle unexpected delays, and to handle a situation like this.

But Leo is right - this is a GNS issue, not a Voyager issue.


Yes, the problem is definitely on my end … Voyager is working correctly. The reason I posted on here was to make contact with someone who is using Voyager and GNS in case I run into future problems with my DragScript and GNS.
Dan, that fixed it … the tablet was polling the windows app too slowly. I fixed that and everything works fine. Thank you heaps.