Getting an initial focus in a dragscript run

I am successfully using Voyager Advanced to run my observatory. Everything is going well, but I have one problem I have not found an answer to yet. It is probably something simple that I have missed, so any suggestions gratefully received.

On the first target acquisition of a run, platesolving often fails as the scope is not yet well focused. In a sequence On Start tab, Point Target on Start is executed before Inject Focus on Start. But you need pretty good focus to make sure the platesolving works (I use ASTAP). When I am in control at the beginning of a session, I can use OnTheFly commands to point the scope at the first target and then execute AutoFocus @ Actual Position. Once that is done the dragscript can take over.

However, this only works if I am at the computer at the start of the run.

I could put a Goto Near Zenith command in the dragscript, but there may not be any suitable stars in the field of view.

At the moment, I am putting a GoTo command in the dragscript to a field with plenty of stars in it, followed by an AutoFocus @ Actual Position. But then I have to change the initial target from time to time to make sure it is high enough and in a dark part of the sky.

Now that I am using Voyager Advanced with RoboTarget, it would be nice to slew to the first target, do an AutoFocus @ Actual Position and then do the precise pointing. Once I have the initial focus, everything works smoothly, I just need a way to automate that.

1 Like

I had the same problem in my observatory as well. Here is how I solved the problem.

In my dragscript I added a focus block just before I do guider calibration. Here’s the sequence:

goto near zenith
simple goto robostar star: Lum filter.
autofocus robostar star: on place

This works every time without fail. The simple goto command does not use plate solving so as long as your mount can put the star on your camera’s chip it’ll work. Single star focus works even if you’re a good bit out of focus. Leo’s focusing algorithm figures out if you are inside or outside of focus. Hope this helps you out.

1 Like

I thought of slewing to the zenith, but wondered if I could guarantee to find a star to focus on. Does it always work for you?

I am in the southern hemisphere and complete a local field focus whilst still at park position. My park position is pointing at polar alignment position. It always works!

You can also use dragscript to move your focuser out, roughly to the position when you achieve focus and run localfield focusing. Works perfectly for me.


Good point. Polaris is a 53 degrees for me. Plenty high enough for reliable imaging, and lots of stars in the field of view. I will try that.

Mmm! Doesn’t reliably work for me. Could be temperature effects on cool down. I must record where the focused ends up for different runs.

goto near zenith
simple goto robostar star: Lum filter.
autofocus robostar star: on place

This is the solution

I tried it last night, but the stars in the FOV were weak, and Autofocus was using 5 sec exposures with the Lum filter. So it worked, but it was slow.

Is there any reason why I should not point at Polaris? Plenty of stars and they don’t move around.

goto near zenith
simple goto robostar star: Lum filter.
autofocus robostar star: on place

please use the blocks just listed, you will have the right star pointed in the field if your pointing is not completly wrong
if you do not want to move so much from where you are remove the first block (goto near zenith)

I’m really confused. There has to be some sort of miscommunication going on here. Maybe I’m making some assumptions that are not valid for your setup. In your original post you stated that you are successfully using Voyager Advance and the only issue is getting plate solving to work on the initial slew to your first target due to it being too far out of focus. I’m assuming that autofocus works perfectly which means that you have all of your filters setup correctly in the Filters Setup tab. You should have a Block in your dragscript that performs a single star focus run before executing RoboTarget. The three commands that I listed in my earlier post need to be run one after the other. When Voyager executes these commands you should be getting two slews, first slew takes your mount near the zenith, you should then see that Voyager is searching for a suitable focusing star according to your parameters in the Filter Setup Tab, then it should make a second slew to the focusing star, then perform a single star focus run all without ever needing to perform a plate solve. The only possible issue I can think of that may possibly cause an issue is if for whatever reason your mount does not slew accurately enough to put the star on your sensor. You never mentioned what mount you have or what sensor you are using. I made the assumption that it can slew reasonably close to the target due to it being permanently mounted in an observatory. If this is the issue then my solution will not work for you and you may need to do as others have suggested. That’s on me, my bad! One other thing, do you crop your sensor when focusing? If so, maybe remove that and use the entire sensor and see what happens. I promise you there is a way to make this work so you can fully automate your runs.

1 Like

OK. I explained myself badly and then misunderstood the solutions offered.

What I was doing (incorrectly) was slewing to near zenith and then executing AutoFocus with Robostar with the AutoFocus OnPlace option ticked. This means the scope does not execute a second slew to a focus star. That is why I was getting the problem of dim stars and increased exposure times because there was nothing much there.

What I should do (if I understand your suggestion) is untick AutoFocus OnPlace and select Use Low Precision Pointing. I will make that change for the next run I get.

I do use ROI to only download part of the sensor as my camera is an older Atik 460ex CCD with USB2. The download speeds are not very fast and downloading the full frame each time in the autofocus would be time consuming. If I have problems I will expand the ROI.

I had a working method, which was to include in my dragscript a slew to a region of sky with lots of usable stars and do the AutoFocus OnPlace. That worked fine, but obviously the slew target would have to be changed periodically as visibility will change over time. I was looking for a way of avoiding the manual update - because I would forget to make the adjustment - and you have provided that. Thank you.

goto near zenith
simple goto robostar star: Lum filter.
autofocus robostar star: on place

Again , the solution is above.

“simple goto robostar star: Lum filter” solve the problem of plate solving because do not solve and also solve the question to update the position because the selection is automated.

autofocus robostar star: on place use a ROI so not needed to download all the field

if you do not want to move so much the mount from the actual position remove the first block (goto near zenith).

I think it is clear. I will try it out on the next clear night.

Thanks you all.

No. Don’t do that as that will force a plate solve. I think I know where you’re going off the rails here. In the dragscript editor on the right hand panel expand Actions then go down to AutoFocus and expand that. I’ll bet you’re using the first command called AutoFocus with RoboStar. Do not use this yet. You need to use the command underneath this one first called Simple GoTo RoboStar Star. This command will find a focus star then slew to it blind (no plate solving). This command will NOT start a focus run. It merely slews your scope to a good focusing star. After this then you can run the command AutoFocus with RoboStar with the On Place box checked. I’m pretty sure this will solve your problem. Let us know if this fixes things.


You are right, I have misunderstood the way the dragscript commands work. I will follow exactly what you and Leonardo have said, and will stop trying to be clever.

I will let you know how it goes.



1 Like