Long AF delay between frames

I’m finding an odd issue with autofocus running with my QHY16200A. I find about a 30s delay between the AF check focus side line and the Exposing line. This is really slowing down the AF run with it often taking around 7 min to complete. I at first thought it was a memory issue, since my side-mounted PC stick has 4GB, but there doesn’t appear to be any acquisition going on at that time. I also updated to 2.2.1e, with the better QHY memory management, but no luck. I’ve also gone through the settings to see if I could find anywhere where I’d have set by mistake a delay that long. Screenshot of the log is below.

Any tips would be appreciated to help me speed up my AF runs. Thanks!


Screen Shot 2019-10-17 at 10.07.22 PM

Hello Gabe,

seems an internal camera driver delay not from Voyager.

Possible cause:

  • driver changing filter
  • driver having difficulties on changing filter (mecanhical)
  • driver have delay on set idle status in firmware
  • driver running internal operation setting up like RBI shot and remove
  • driver communication problems
  • driver bug
  • internal difficulties on manage shutter

When start appear this problem ?
Have you tried to check driver version actually avalaible ?

Voyager code for ASCOM is equal for all camera (some exceptions for old or problematic camera that have dedicated ASCOM management in Voyager). There is no code in Voyager to create this delay.

Please send us the log file to support mail to understand if is a Voyager problem, also you can activate in voyager setup -> voyager tab -> box logging -> flag ASCOM Extended Info and retry to obtain more info about ASCOM driver operations. Also you can activate ASCOM log in your driver (if possible) to understand Driver side what happens.

All the best

1 Like

Thanks for the suggestions Leo. I’ve updated my drivers and still am finding the 30-35s delay occurring for all my exposures.

DM sent with log attached.


Thanks Gabe,

i’ll look inside to understand.

I can confirm that I don’t have any issues anymore went from 30-40s delay to 0.5s delay between Action Start to Exposing... . Not sure exactly what made the change - I am using 2.2.1h from 2019-10-21. I did revise systems and am now using a Pegasus Astro UPBv2, but am still using the old PC stick computer for this testing. The old system also relied heavily on ethernet connections as well. The PC stick has the following software versions when I inspect the FW and CCD drivers:
FW Driver:
QHYFW Version: with filter names set
CCD Driver:
FW: 17-5-2


We have tried all camera with internal filter wheel and filter wheel from QHY, thanks to Italian retailer Tecnosky
QHY have released a driver that solve the problem.

All the best

1 Like