New problem connecting to Mach1GTO since upgrading Windows 7 to Windows 10

Everything was working ok with Windows 7, however because of problem with Web Dashboard and because Microsoft has stopped supporting Windows 7, I upgraded it to Windows 10 last night. However I have nothing but trouble since then.

The fatal problem now is that I cannot connect to the AP Mach1GTO properly.

If I launch Voyager first, I can connect to the mount, but then PHD2 cannot connect to the mount. It seems that PHD2 will try to open a new instance of the driver, when Voyager is already connected to the mount. Because there is only one mount and it is already connected, PHD connection to the mount fails.

If I launch PHD2 first, PHD2 can connect to the mount, but then Voyager cannot connect to the mount. It seems that Voyager is trying to open a new instance of the driver, the PHD2 is already connected to the mount. Because the mount is already connected, it refuses to connect to the second instance of the driver.

This problem is driving me mad.

What is worse, the Windows 10 upgrade did not solve my problem with Web Server for Dashboard, but I need to fix this more important problem first.

Please help

I solved the problem! The problem is because Voyager was running in Administrator mode. When I turn off Administrator mode, everything is working normally again - for the mount anyway.

Is it better if everything runs in administrator mode, or is it better if everything is not in administrator mode?

I spoke too soon. Voyager is complaining about not being to connect to the mount again. I will now try to turn on Admin mode for PHD2 and Voyager and see what happens.

Still no good. I tried PHD2 and Voyager both in Admin mode and they both insist to open their own instance of the AP driver. So it is not working.


Run Voyager in Admin mode and let it manage all underlying applications. Do not open PHD2 first.
You do have to set up PHD2, your AP ASCOM driver, etc before. Open them with Voyager closed, test connection to your mount, guide camera, etc. Save settings and then open Voyager, set them properly in your Setup tab and start connecting from the Startup menu.
It works, it just needs to be done in a certain order with the underlying applications pre-configured.

Thanks. But that’s what I tried first. I.e. let voyager launch everything. with this Phd2 fails to connect to the mount. It is a problem with the windows 10 upgrade. I did not have the problem until the upgrade.


I run Windows 10 with its latest upgrades; I don’t have this issue. Make sure PHD2 works on its own. Close it fully - check in Task Manager that there are no ghost sessions running. Then try Voyager again.


Dear Henry,

we offered our help to solve your problem and we offer now again.
You have all contact to ask directly support, please allow us to support you.

If you start Voyager for first and leave it open all the applications and driver you not have this problem.
If you start before something that isnt work in admin mode and after start Voyager, Voyager will start like admin and ( depends on how drivers is written from constructor) can start another istance of application or driver.
If you have created the situation just reported in the last phrase you must restart pc or kill the process manually because driver remain running and if you change from admin or not admin mode the other applications the driver are already running.

So just keep calm and ask support or restart pc and start for first Voyager or allow us to go remote to your pc.

If you report that Voyager is not useful for you (like i read in a pubblic forum) we will happy to refound you about money, we are for first AP not a big company looking only to gain money.

Dont tell me i’m rude … i’m just pragmatic and greatly honest.

All the best
Leonardo Orazi

I’m adding … if you have done an upgrade of OS the situation of drivers of your setup could be wrong.
I think a reinstall of all driver with the correct version should help … but we need to understand which part of connecton give you a problem.

All the best

OK. I will lodge a support ticket. Thank you Leo.

The problem (PHD opens a second instance of driver cannot connect to mount) is still there even when I loaded Voyager as soon as the computer starts, and let Voyager starts PHD2. So I will definitely need your help to get this fixed. You may be able to look at the problem with the web server as well.

I am very reluctant to install another piece of software (Teamviewer, Skype) on my Mac which I uses for work as well (for security reason). However, I can probably have it installed on the Voyager PC itself if I can borrow a monitor from somewhere so that it is not in headless mode.

A Teamviewer session with Leo has fixed all the problems! I am very grateful.

For posterity, the problem with the web server is to do with the port. For some reason on my PC the port I need to use is 8081, not the default 80. Leo figured out the problem so its all working fine now!

Thank you Leo!


Glad it’s sorted. What was the issue with PHD2?

AP driver have some tricky on release for multi client. If you connect mount to PHD2 , when you disconnect setup in Voyager you must flag on the one in this image

to allow AP driver to release all the instance or the next time this driver will be connected by Voyager but not send information about mount (!).

All the best

1 Like

You are welcome Henry.
You are talented Astrophotographer … happy we can help you !

Your port 80 and 8080 are busy from other service in your PC.

All the best