No automatic ramp-down cooling for SX-CCD


I am new to Voyager and have some difficulties in controlling the cooling of my StarlightXpress CCD. This is a screenshot from my current camera setup:

When I use these settings and command the camera to cool, it rapidly (within 10 to 20 seconds) cools from ambient temperature to the set temperature. In contrast, the warming follows a ramp as defined in the setup. If I uncheck the option “Temperature control allowed by camera”, cooling isn’t possible at all.
I would prefer to cool the camera slowly over a period of a few minutes.

I’m using the latest SX-ASCOM driver I was able to find via the SX-Website.

Any ideas?


Björn, your camera doesn’t need a ramp to cooling down. The glass is of really nice quality.
In this image the settings just define the ramp. Using or not the ramp depends on what you will select in sequence on in the camera cooling widget.

Hi Leonardo,

Thank you for your answer!

I just “played again” with the settings. If the option “Temperature control allowed by camera” is unchecked, it doesn’t do any cooling. It reports the following messages:
Screenshot 2023-04-07 at 09.18.18

I noticed also different behavior for the buttons “Set Point” and “Cool Down”. If I push “Set Point” it does a quick cool down. If I push the “Cool Down” it ramps. I couldn’t pick up this difference from the wiki page?

Another question: the command windows always proposes -20C when Voyager is started. Would it be possible to use the preset from the setup window (“Default Temp. Cooling”)?


Hi Björn

if you not set the “Temperature control allowed by camera” Voyager assume the camera havent cooling.
Set Point button will use the internal firmware of camera to cooling down, Cool Down button will use the ramp define in Voyager.

No is not possible to preset the camera cooling value provided in the command window. Usually its something rarely used and the value changed is not stored.

Please if you have more questions about use the support email.