Plate Solve FIT issues from OnTheFly window

After connecting to devices (simulated or real devices), I am trying to plate solve an image captured by SGPro last year using “Plate Solve FIT” (Solving Reference FIT) from OnTheFly window and I get the following message:

Run-time error ‘6’: Overflow

The PlateSolve2 window displays RA/Dec correctly from my FIT file but it shows 0x0 next to arc minutes button.

I am able to successful plate solve this image with Plate Solve 2 if I run it from the “Setup” window and under “Plate Solve” tab. I click on Setting button and Plate Solve2 window pops up, I manually open the FIT file from Plate Solve2 window and clicked on “Plate Match” button and it solves within a few seconds. Also it shows 44x35 next to arc minutes button.

I think the source of the problem is when Plate Solve2 window shows 0x0 next to arc minutes button if running “Plate Solve FIT” (Solving Reference FIT) from Voyager’s OnTheFly window.

Here is a FIT file I am trying to plate solve with Plate Solve2 from OnTheFly window using “Plate Solve FIT” (Solving Reference FIT) feature:

Please advise.

Thank you,

I can’t see inside now. But if the fit isn’t referenced correctly doesn’t work. You can use blind solve. I don’t know SGP how works.

I don’t think it has to do with SGP. All SGP did was captured the image in FIT file. I uploaded the FIT file for you to evaluate the FIT header and see if anything is missing that Voyager needs. Have you tried to evaluate my FIT file?

I tried to blind solve from within OnTheFly windows and was not successful. About 2/3 completion of uploading to, it aborted due to internet error. I’ve tried 3 times without success.

You need to download the FIT file first before looking inside the FIT file.


When I come back I try …

Just trying to help out. I downloaded the FITS file, then sent it to

Your FIT work with all plate solving system in Voyager except PlateSolve2
I attach some test about 2 plate of the 7 ready to use.


Nova online:

I found a strange data format in your FIT header that cause Voyager to calculate FOV with infinite value results … this create a OVerflow error in PlateSolve2. Now is to late for me… tomorrow i’ll try to understand better. This is from the log in Voyager:

2019/01/13 01.42.43 565 - DEBUG - [Execute External Script/EXE ] - [EXECUTE_EXE_Code ] - Arguments => 0.408916099331838,0.534128928751998,Infinity,Infinity,999,C:\Users\leonardo\Downloads\,0

All the best

PS For Nova online try to check your internet connection … or the service was down or busy.

Thanks for looking into it.

The strange part is from within Voyager in Setup window under “Plate Solve” tab, I clicked on Settings button (left of Download Catalogs button), Plate Solve2 window pops up. Then I manually open the FIT file from Plate Solve2 window and it successfully plate solves within 2 seconds. Also, it displays 44x35 next to arcminutes button instead of 0x0.


Peter in this case use the button.

All the best

Your automation program use int16 type for focal lenght … Voyager use float type.
This is the problem … i add int16 as allowed type for focal lenght.

Like i said above , use the button. In the next release you’ll find the the patch if you are interested.

All the best

It now works.

Thank you,

1 Like