Potential windows 10 update breaks voyager!

I’ve never had a single instance of Voyager freezing or crashing on me for the 5 weeks that I’ve been using it. Today, my observatory laptop installed 3 new windows updates (KB4480966, KB4100347, KB4480979) and now anything run through On The Fly or Dragscipt completely freezes the program. No error messages or anything. The only way out is to end the program in Task Manager. I am able to issue commands through the Command window only. I am by no means a computer guy but it seems awfully coincidental that this started right after installing these updates. Hopefully Leo can see whats going on here. I would roll back the updates but I’m not sure how to do that.

Mark

After a little more research, it would seem that the most likely culprit is KB4480966 which deals with securtiy in PowerShell endpoints. Here’s a link to the update. The other two updates seemed pretty minor to me but what do I know. I’m trying to figure out how to roll back that update. I am running the laptop through Chrome Remote Desktop if that makes a difference.

I figured out how to uninstall Windows update KB4480966. Once uninstalled, everything works as expected. There is something in this security update that breaks Voyager so don’t install until there’s a fix for this. I’m going to edit my original post to reflect this. Another reason to hate Windows!

Hi Mark,

sorry for delay in answer … i checked this morning (for me) the windows update but all work fine with simulator. When i have sky clear i test it on sky. Probably its something else that going away like drivers. Voyager was born to don’t crash or hang , have an external timer for each actions to kill threading that not give response and each actions is threaded. I mutuate this from my skill in real time process. Some driver can hang in kernel space and this mean pain.

I’ll update you about when i have news

All the best,
Leo

Any chance that the problem has something to do with running my laptop remotely through Teamviewer?

Hard to say it … usually after an update windows restart and you must to reconnect Teamviewer.
We can wait if someone with W10 give me more info about. You can delay the update for some months in W10 try to do this for now

I just ran Voyager successfully after installing this update. I am accessing the observatory computer via TeamViewer. I ran OnTheFly and DragScript actions without a problem.

That said, I have no doubt there is a problem happening with MKuehner’s setup! Just adding a data point that this update is not breaking everything. My configuration:

Camera: TheSkyX -> ASCOM to ASI1600MM
Mount: ASCOM -> CEM60
Guiding: PHD2
Planetarium, Plate Solve, Blind Solve: TheSkyX
Focuser: ASCOM -> Moonlite NiteCrawler
AutoFocus: Voyager RoboFire
Rotator: ASCOM -> Moonlite NiteCrawler
Flat Device: Alnitak

Good luck finding this!
Rowland

1 Like

That’s interesting. When I get home tonight I’m going to load up Voyager with simulators and see if everything works. Then I’ll start connecting my equipment in one by one until something breaks. The odd thing is that if I go into On The Fly and look up NGC 891 and perform a slew my mount (Paramount MYT connected through TheSkyX) actually does the slew however Voyager freezes and in the Monitor window nothing gets reported. It’s completely blank. If I command the mount to Park through the Command interface, it works perfectly and the status shows in the monitor window. If I take Voyager out of the loop, everything works individually as far as I can tell. I need to test more tonight. When I rolled back the update everything works so there’s something in that update that’s affecting my setup. I’m going to officially ask Leo for a Linux version of Voyager. (Just kidding. Maybe)

Mhhhh this sound strange, try to contact me with whatsapp when you will connect tonight … i try to remote support you to understand. DCOM is the last problems with TSX and W10 and user permission. Linux … maybe … we switch all to indi server and recompile in Mono under Linux. Voyager work with abstraction for interface … INDI can be one of the interface implemented for control.

Just for info, the problem is solved. The patch in Mark PC had removed the admin privileges to the Voyager’s start icon on desktop and comprimise the windows layout profile of Main Windows in the operative system. Resetting layout in Voyager with dedicated menù voice and restarting all fix the problem. To allow again to work with full functionallity Voyager i redo the admin privileges to that it need to be a real system integrator. Thanks to Mark to allow me to do a remote check and fix.

All the best
LO