Problem connecting PHD2 to Voyager

Guide Connection Error = Error during PHD2 Connection Request : [NON_ESEGUITO] PHD2 not respond on free ports

Hi all,
I’m running the latest releases of Voyager, PHD2 and the 32-bit TheSkyX Pro on a MyT mount.
I’m having an issue with Voyager connecting to PHD2 and am getting the error code above. Voyager will start PHD2 (although I had to increase the timeout to 30s) but not connect. I have the PHD2 server enabled, I’ve checked that the firewall is set to allow outside communication with other software and PHD2 was installed in the default file location as far as I know. Within the Voyager guiding setup tab, I have the default server setting connection selected and not the localhost/4400 (although that doesn’t help either).
So I can see the error message seems to be saying that ports for the connection aren’t matching somehow but I don’t know how to troubleshoot this and I also have not found any relevant posts in the forum here.
Does this make sense to anyone ? I’d really appreciate some insights as to what I’m doing wrong here.

Hi Garry,

if you need official support use this:

Either way, you probably haven’t turned on the PHD2 server or allowed Firewall exceptions in the OS when requested. This is a good start for checking.

All the best

OK, thanks Leonardo.
The PHD2 server (Tools dropdown menu) was enabled before.
I did find another location in Win10 to allow all firewall exceptions for PHD2 and restarted the pc. This time Voyager seemed to load and connect PHD2 with a green-coloured notification in the Startup box that reads:

Does that seem correct and the expected response ? I remember when I had PHD2 already running when I hit “Connect” in Voyager, this came up as well but there was no link between the guiding trace in the PHD2 window and the smaller one in Voyager.
I’ll try it again tonight and see what happens.

Yes its a correct response.
Guiding graph will be populated only during guiding if guide started by Voyager.

All the best

OK, thanks, that’s reassuring !

In case … open a support request for remote session

Thanks Leonardo,
Everything in the sequence I tested last night worked great, except for the clouds that rolled in around 2AM!