QHY Camera with internal filter wheel [SOLVED]

We continue to have problem of timeout on changing filter for shot in QHY Camera with internal Filter wheel like the QHY9000A when used in ASCOM internally to Voyger. Someone of you have the QHY16200A , in october of 2019 we asked to fixed the problem to the QHY developer and someone of you reported is fixed with a new driver.

Could you confirm (users with this kind of cameras) that you work normally without problem ?

Sorry to bother you but i dont remember exactly the users.

All the best

1 Like

QHY camera with internal filter wheel (the ones with the Final A code in the name) are declared not supported on Voyager if used with ASCOM driver directly inside Voyager.

All the best

I was one among those having issues. Things have been working fine since I installed the QHY driver supplied by them. Here are my driver versions.

Screen Shot 2020-05-20 at 10.08.46 AM
Screen Shot 2020-05-20 at 10.09.07 AM

@Voyager You say: " QHY camera with internal filter wheel (the ones with the Final A code in the name) are declared not supported on Voyager if used with ASCOM driver directly inside Voyager." Is there a reason for this change? Do you know of another means by which it might be supported (I only ask since you say if used with ASCOM driver directly inside Voyager).

They have changed something in the SDK/driver and the problem coming back.
I’m in contact with QHY staff to understand, at now i must suspend support in Voyager for QHYxxxA camera. Please do not update the driver and SDK or you go back with the problem.

You can use Maxim like Voyager camera if you have instead ASCOM direct in Voyager, this if you update the driver ASCOM. If for you work as is not update ASCOM driver.

Can you confirm you running Voyager like administrator ?

All the best

Ah, I see. Thanks for the info Leo! Yeah, with the fiasco I had w/ the QHY drivers, I’m not updating anytime soon :wink:

Yep, I’m using Voyager in Admin mode.


Thank to great support from QHY!
They have solved the question so camera is again compatible.
This issue (with different delay) affect also the CFW3xx.

The driver ASCOM that solved is the V20.5.29.0 which contains also the right SDK dll

Thanks again QHY for the efforts put inside, really never see this kind of support to Voyager.
Usually we are too small to be listen.

All the best
Leonardo Orazi


Can you tell me where V20.5.29.0 is located? Is it at QHY web site?


Hello Peter,

this is the website of QHY:

Where is exactly i cant help you. I received a version for test. You can contact then and ask where to download.

All the best

I already looked at QHY web site. So far I’m unable to find it. I guess QHY is testing to make sure the new driver is stable before making it available to the public.


I cant answer to you if they will pubblish or not, i wrote QHY to know where to download it.
If I will receive an answer i will pubblish here for sure.

All the best

Thank you Leo.


Hi I have made the new version downloadable via dropbox

I add the download from Jaspal isn’t official download !
For your info.


All the best