Send seek home in place of park for ioptron mounts

I recently bought an ioptron CEM70G mount and am mostly very happy with it. The only thing that I have issues with is parking positions. Would it be possible to have an extra ioptron related flag in the mount setup page to have Voyager substitute a homing command instead of park if park is requested? Something like “Send home instead of park”

It is not ideal as the home command Voyager sends is a sync event so any plate solved syncs would be lost, but the home position has been accurate enough for PS2 to near solve for a sync sync after homing the mount, a blind solve has not been required for the initial sync after homing.

I am asking for this one as my preferred parking position (Counterweight down, pointed at the pole) is not available as a preset in the ioptron mount driver and you can not effectively set it as a custom position either. Possibly due to being so close to the pole, it will move to the correct position but then keeps tracking, which forces Voyager to wait until the parking timeout occurs.

1 Like

Hi Paul,

please use the home command or DragScript Home block after choose one of the 2 home positions of the IOptron on the Voyager mount settings. Was developed based on IOptron users some years ago. Or use ASCOM set park, if not work this is a bug of the ASCOM driver you could ask to solve.

Home position from Voyager is an IOptron command, no sync from Voyager.

All the best

IOptron home options:

Home command from widget:

Search for homing block:

Hi Leonardo, I already use the home button if I am driving the mount via the mount widget instead of in a sequence or dragscript and that works exactly as I expect. The mount syncs to the home position each time it is used but that is a function of the mount driver and it does not cause me any issues anyway. I may start using the “Built-in Zero Position like HOME” flag to avoid the sync action that the mount does and some wear on the mount (It sweeps past the home position on each axis slightly to “find” it and then returns to it) and I would just need to start each session by seeking home via the ioptron software to be sure I have the correct home position.

Why I was hoping for a flag to send a home instead of a park command would be it would allow most of my dragscripts to be shared between my two setups without modification. Most of the differences between the setups are managed in the setup tabs, but the other mount does not have a home function so I can’t use that command with it.

The positioning information actually disappears from the park setup window of the ioptron commander software when the mount is right on the home position, so it looks like a deliberate design decision that is keeping it from being used as a park. I am putting a request in with ioptron to see if they will add the home position in the parking options but I imagine it will take some time if they will add it at all. The other selectable park positions are zenith or horizon positions one one side of the pier or the other which I don’t like as space is a little tight and I am much more likely to bump into the scope or counterweight bar in the dark.

If it is not worth doing (Or at least not for one user) I will just have to generate two versions of my dragscripts, one using the home command for the ioptron and the other using park for the Orion Atlas.

Sorry Paul but i cannot help … in Voyager you have:

  • park in ASCOM
  • park with set ASCOM
  • home zero with Ioptron driver
  • home no zero with Ioptron driver
  • simulate parking with position alt az
  • sync on park to exit from a not saved position of the mount driver

nothing else is possible to do.

To do this use the dragscript home block and use one variable count for set if use park or mount.

All the best

If it is not possible then it is fine, I can keep working around it and hopefully I can talk ioptron in to adding the home position as a preset park.

I may start using the “Built in zero position like home” flag to prevent the sync and extra movement of the mount, everything else I can work around. All I have to do is start the session by seeking home in the ioptron software to ensure the home position is correct, in case I have missed the home position by one tooth on the ring gear as I set up each night.

Even if I do park the mount, the preset park positions are all safe for the equipment, I just don’t like them very much.

I have the CEM 60. I assume the software is nearly the same. I have had a lot of success with setting the park position and then it is fine. I just updated again yesterday and it worked perfect last night. I did zero position on the mount. In Voyager, I went to the SetupForm, Mount tab, under park/unpark clicked Ascom Set park. Set it right where it is and was done. This morning when I came out, the sequences of the night had finished, the mount was parked correctly and the camera warmed and disconnected. The next night, plate solves work perfectly.

I am not sure that it is quite the same. I believe the CEM70 uses a variation of the CEM120 driver, not the CEM60 one. I have had issues (which I am following up with ioptron) where the commander software looses the user settings between sessions. One is the users park position setting which defaults to 0 - 0 alt-az. In the southern hemisphere that produces a safe but strange park position with the OTA horizontal but pointed backwards! In the northern hemisphere it would match one of the horizon park positions. The other setting that it looses can be more troublesome which is the degrees past meridian before safety limits stop the mount, the default it goes back to stops the mount at the meridian which would prevent Voyager from managing the meridian flip (The mount drivers fault, not Voyagers) so I check that that one has been retained on each setup. I have not seen many reports of the driver loosing settings so I am assuming it is something peculiar to my setup on the PC.

I have not tried the ASCOM set park, but it is known that at least the CEM70 will not park properly at the home position via the hand controller or commander software, I would expect the ASCOM set park to produce the same result but I will test that today.

1 Like

Paul, like I said there are nothing I can do in Voyager to help you.I suggest you to open a ticket to the IOptron support.

All the best

Yes, I will do that.

I just checked, and using the ASCOM set park function within Voyager performs the same action as setting a custom park position in the ioptron commander software or hand controller. When it is commanded to park it will move to whatever position you have set but if the park position is the same as home, it keeps tracking. For the time being I will just switch to using the home command in the dragscripts for this mount instead of park as that will stop the mount where I want it.

It seems that the current commander version does not respect the “Built in zero” flag in Voyager either, it still seeks home with that selected at least for the CEM70. ioptron may have changed something since you implemented that flag.

The “built in zero” flag is not a flag, is a command to send in driver to do home like requested from IOptron protocol and I don’t think this is the problem , better to ask to ioptron. An homing that continue tracking is a bug. If you want in voyager you can send a stop tracking after the home if this solve their problem.

All the best