Shutter status "ERROR" after startup

Hello all together!

I’m just starting to get into Voyager. I run a remote observatory and was looking for a successor for CCD Commander. Voyager actually covers everything my “wish software” should be able to do. :slight_smile:
But, as so often, it tweaks a bit at the beginning. I have a roll-off-roof, which is controlled with a dragonfly from seletec. For this there is an Ascom driver and I also manage that a connection is established in Voyager.
But in the command window I get an “error” in the shutter status. But I know that the roof is closed and the corresponding sensor also reports this. You can see this on the dragonfly interface.
I can open the roof in the command-section with “open” and then close it with “close”. Then the correct status is displayed. The “error” comes only directly after the connection. I suspect that the “error” could make some other actions impossible - it would be great if the correct status was entered.
It should be mentioned - the weather status is “safe”, if that plays a role.

Anyone have an idea what my problem might be?

All the best,


Markus, Voyager report status from ASCOM Driver.

Initial status is set to error until first communication with driver.
Error mean status not recognized, communication error.

I will check about, I have a DragonFly just here.

All the best

Hello Leonardo!

Thanks for your answer!
I have tried quite a lot today. Among other things I tried Viking as trial, because I would like to be able to turn my devices on and off as well. But I don’t know if viking plays a role here.
In any case, I put together a little flow in DragScript (see attached). It does the following:

  • connect to the I/O Card (=dragonfly) via Viking
  • activate relay 6 for 3 seconds, then deactivate it again (this switches the mount on)
  • wait 3 min (during this time the mount boots up)
  • connect setup (CCD, filter wheel, RoboFocus, dragonfly,…)

After that, the status of the roof is no longer displayed as “error”, but as “closed”. That’s right now. Let’s see if this is always the case now. This is also the case when I only use StartUp to make the connections.
I had installed today in the meantime a new software for dragonfly, which also installs an ASCOM driver. Unfortunately, I can not say whether it has changed compared to my “old”. However, the new software is uninstalled again, because it would also have needed a new firmware (I don’t like to upgrade remotely). Now the old software is running again - but possibly the new ASCOM driver.

Dragonfly software: 5.0.0
Dragonfly firmware 4.1 (is always tricky to upgrade something remotely…)

All the best,

Hi Markus,

Viking not make any rules on status. ASCOM standard tell about reporting Error status if system is not able to recognize shutter status and this is safe. Always better for a system to start from a know situation.

Thanks for trialing products.

All the best

Hi Markus,

Jaime from Lunatico here, with Leo’s permission :slight_smile:
I seem to recall that shutter error problem from very long ago - I understand you prefer not to update.
Why don’t you contact me directly (jaime - at - - if I’m right we can solve it in no time.

Best regards.

1 Like

Thank Jaime , you have all permission on this forum and i’m happy you are here

All the best

1 Like

Hello Jaime!

Thank you for reporting here directly, great!
Currently it looks like the “problem” is solved, the correct status is displayed. Whether this is due to a new driver (possibly installed) or because I am now running dragonfly as admin, I can’t say.
Should “problem solved” change back to “problem present”, I will be very happy to come back to your offer.
And an update of the firmware I do when I’m there again (unless it absolutely must be before). I will also contact you beforehand to be on the safe side.

Great support here, thanks!

Thank you, Leonardo, and thank you also, Markus. :slight_smile:

I’ll be online!