Slew rates in LFEP ASCOM mount driver are not considered

Hi everybody and shouts from Berlin,

I hope someone can help me sort this out. It’s rather weird. I haven’t had this issue before on my old setups and I’m rather startled by this.
I’m having problems that voyager seems to be overriding my slew rate constrictions on my LFEP mount driver, thus stalling the motors on my mount. Means it doesn’t slew at all, it just rattles and shakes… :frowning:

On my LFEP ASCOM driver, the max. slew rate is limited to x420.Anything faster is not supported by the 24 volts power supply on my rig.
When I connect voyager, the mount always slews on x640. Doesn’t matter if the slew command is executed in voyager or cartes du ciel. When I shut down voyager and connect cartes du ciel directly with the ASCO driver again, the slews work on x320 again.
I don’t have this problem when connecting other programs to the LFEP ASCOM driver. Like Cartes du Ciel, Starry Night, Ekos, SGP etc. All slewing operations are executed at the defined x420 speed.

So I suppose something doesn’t gets recognized from the ASCOM driver.
I’ve tried setting restrictions on the ASCOM profile manager in the security tab, but that doesn’t change anything either.
Maybe I missed a button somewhere?

Cheers and thanks in advance,

G11 with an Escap530 on RA & an Avalon belt motor on DEC, powered by a LittleFoot Elegance Photo, running with 24 Volts,
ASCOM Driver is the latest developed version v1.5.3 from 2016

Win 10 - 1809
build 17763.805

Welcome Bob,

Voyager cannot change slew setting … cannot do this because is not programmed to do.
My opinion is to check setting using the button in ASCOM Dialog Chooser in the mount setting tab of Voyager. This because Voyager run as administrator and setting of this user can be different from setting done from application started in normal mode, depend on how developer programmed driver. Probably the setting like admin have default values.

Best is to start all from Voyager and leave Voyager open all.

All the best

Hi Leonardo,

thanks for the fast reply. :slight_smile:
Aye, the admin mode sounds plausible. And I agree, Voyager shouldn’t handle any slewing speeds, that’s for the driver to take care of.
In Voyager, on the ASCOM mount chooser, without being connected to the mount, I can only set the connection (LAN or COM etc). But after connecting Voyager with the ASCOM driver, my virtual Handset pops up and there is the setup tab where I can set the slew speeds.
But nothing there is different than before, those settings are already set.
I tried running the underlying LFEP server in admin, but still no luck. The slewing limit set in the driver is not recognized, it’s always slewing at full speed.
I do think it’s a problem with the driver. And I wouldn’t put any more effort in this Leo, the LFEP is a dead product since long ago, like the FS2. At this stage with Voyager there are surely other things more pressing than this.
Lucky me that, at least, it still runs with slew limits on the other software. :wink:

Since the LFEP, as the FS2, is completely obsolete by now, I’m going to try and see if I can fix this on the hardware side.
I’ve just ordered a 30v 5A lab power supply. Maybe by ramping up from 24 to 30 Volts will give the motors enough power to slew at max. x620. Although I’m not really comfortable with slewing almost 18 kilos at that speed and with such a big leverage from a 6” refractor on a G11. And if that’s not working I’ll pass on.

A question to the FS2 Users, that run without the 40 Volt booster (or even with 12 Volts), which is needed to achieve max slewing speeds, how are those speed limitations handled?
Or am I the only one that is actually using a slew speed limitation and everybody else always runs at max and that’s why it never came up before?


Sorry Bob, how i telled to you Voyager cannot change slew velocity.
Probably there is some way to do the right setting in your driver but i dont know how to help. If you are able to find the source code of the driver i can try to fix it. Or try to ask to the developers if they have a solution to suggest to you or to us.

All the best