The requested operation is not permitted at this time


#1

Hi,

I’m a new user and just getting going with this software. I’ve managed to get imaging going but now want to get my HiTec Roll off Roof observatory configured. I think I’ve done all the right things since the HiTec controller software starts when I connect. If I then use ‘Open’ in Commands->OBSERVATORY I get the following message:

21:30:00 817 - Action Start
21:30:00 829 - Opening Dome Shutter …
21:30:00 928 - Action Aborted for Error : [(ASCOM) ASCOM.HitecObs.Dome] Open Shutter Not Done (The requested operation is not permitted at this time)
21:30:00 932 - Action Time [ATOMIC_DOME_CMD] => 0 [m] 0 [s]
21:30:00 936 - Action Time Mobile Mean [ATOMIC_DOME_CMD] => 0 [m] 0 [s]
21:30:00 940 - Action End : FINISHED_ERROR
21:34:28 018 - Setup Disconnect Request
21:42:51 501 - Setup Connect Request

Is this an error from the ASCOM Observatory software or something I’ve misconfigured ?

BTW, this software looks really excellent and more importantly seems very reliable and robust.

Many thanks
Robert


#2

Dear Robert

This error coming directly from the ASCOM driver you use for Dome during the OpenShutter ASCOM method.
Voyager can only handle this exception. I suggest to investigate on driver setting, if there are some conditions doesn’t allow opening shutter or if you have connected the driver in more than one application or communication was broken with the electronics.

Thanks for your time trying Voyager.

All the best
LO


#3

Many thanks for replying so quickly.

I think it must be the HiTec ASCOM driver which has always been a bit suspect.

Best
Robert


#4

Robert
As you know I have the same RoR controller as you do. I was getting disconnections from it using Voyager when setting the ASCOM driver as standard. I switched to ASCOM Dome ConnectionLess Interface and the errors have gone away and I have used Voyager for two full nights (with RoR opening and closing repeatedly because of passing clouds) with no problems or disconnections.
I suggest you try that.
Roberto


#5

I will add this to the Wiki :slight_smile:
Rowland


#6

Thanks Roberto,
connectionless dome mode is a way that Voyager use to solve some ascom driver problems, when drivers doesn’t store connection status or lost connection status, like Lunatico I/O card with Dome Ascome Driver. Probably this Hitec must be used in the same way.

All the best
LO


#7

Leo
Thank you. Yes, it must be some latency issue with this controller as it has happened to me in other applications. The ConnectionLess dome driver solved this issue yet maintains functionality during the whole session which is excellent.
More thumbs up for Voyager! :+1:
Roberto


#8

Hi Roberto,

I just tried that and still the same error message. My HiTecObs driver is Version 1.6.2 which appears in Voyager as ‘HitecRoof - ASCOM Driver. Version: 1.6 1.6’. The HitecObs App says 1.4.3.

The strange thing is that Voyager starts and stops the little widget and correctly reads the dome position.

Is that the same version you’re using ?

Thanks
Robert


#9

Robert
I’ve got the same drivers. Have you disabled your PC turning off the USB connections to these devices? That was a problem I was having years ago. Go to device manager, choose the USB device and in power settings disable that option.
Roberto


#10

Thanks Roberto,

I had that as well and did disable power management a while back however after rechecking I found a few that needed to be reset. Unfortunately that didn’t make any difference.

Could you check the version info on HitecObs.exe ? Mine says version 1.4.2.1, size 1.13MB and date modified 18/02/2015. Unfortunately Hitec weren’t very good at version numbers and sometimes released an update with the same version number.

Many thanks
Robert


#11

Robert
I don’t use the HitecObs.exe. You only need to set that once and it should not be open or connected when the ASCOM driver is enabled.
When I connect to the ASCOM driver through Voyager (or any other application for that matter), a small window comes up with HitecObs 1.7.1 at the top showing two small rectangles: one for Closed, one for Open.
image
Do you see that one?
Roberto


#12

Ah ! My HitecObs mini window says 1.6.2 and not 1.7.1… does yours contain a fix ?


#13

No idea! That’s the last version I received from Hitec back in 2017. Send me a PM and I will send you a copy of the installer mine is HitecObs_v166_UNI_SETUP.exe

Roberto


#14

PM sent.

Whenever I’ve asked Hitec they’ve always said I have the latest version !


#15

File sent. I hope that solves your problem!


#16

I wish ! Unfortunately not, still no joy with this.

It very much looks to me as if the Open Roof request never got to HitecObs as the ASCOM trace file for it contains repeats of the following:

21:41:26.061 ShutterStatus shutterClosed
21:41:26.061 Slewing Get False
21:41:26.061 Slaved Get False
21:41:26.061 CanFindHome Get False
21:41:26.562 Slewing Get False
21:41:27.063 Slewing Get False
21:41:27.063 ShutterStatus shutterClosed

This is what I see in the Voyager monitor:

21:41:13 202 - Action Start
21:41:13 208 - Opening Dome Shutter …
21:41:13 312 - Action Aborted for Error : [(ASCOM) ASCOM.HitecObs.Dome] Open Shutter Not Done (The requested operation is not permitted at this time)
21:41:13 318 - Action Time [ATOMIC_DOME_CMD] => 0 [m] 0 [s]
21:41:13 324 - Action Time Mobile Mean [ATOMIC_DOME_CMD] => 0 [m] 3 [s]
21:41:13 330 - Action End : FINISHED_ERROR
21:41:21 268 - Action Start
21:41:21 275 - Closing Dome Shutter …
21:41:23 275 - Dome Shutter Closed
21:41:23 297 - Action Time [ATOMIC_DOME_CMD] => 0 [m] 2 [s]
21:41:23 327 - Action Time Mobile Mean [ATOMIC_DOME_CMD] => 0 [m] 3 [s]
21:41:23 334 - Action End : OK

ASCOM diagnostics 100% error free, still debugging…

Robert


#17

It’s better if you show the 2 log in the same time otherwise is not useful.

Have you try to asked what the error mean to driver developer ?

Voyager polling status each 1s to driver,

All the best
LO


#18

The developer is not very responsive - he hasn’t ever replied to my emails.

This is both logs from Voyager connecting:

22:27:09 370 - Setup Connect Request
22:27:24 041 - Action Start
22:27:24 062 - Opening Dome Shutter …
22:27:24 266 - Action Aborted for Error : [(ASCOM) ASCOM.HitecObs.Dome] Open Shutter Not Done (The requested operation is not permitted at this time)
22:27:24 271 - Action Time [ATOMIC_DOME_CMD] => 0 [m] 0 [s]
22:27:24 275 - Action Time Mobile Mean [ATOMIC_DOME_CMD] => 0 [m] 3 [s]
22:27:24 279 - Action End : FINISHED_ERROR

22:27:18.853 Dome Starting initialisation
22:27:18.903 Dome Completed initialisation
22:27:18.904 DriverVersion Get 1.6
22:27:18.904 InterfaceVersion Get 2
22:27:18.904 Description Get HitecRoof - ASCOM Driver
22:27:18.908 Connected Get False
22:27:18.910 Connected Set True
22:27:18.913 Connected Set Connected
22:27:19.007 Slewing Get False
22:27:19.008 SupportedActions Get Returning empty arraylist
22:27:19.009 Slewing Get False
22:27:19.013 DriverVersion Get 1.6
22:27:19.013 InterfaceVersion Get 2
22:27:19.015 Slewing Get False
22:27:19.015 Slaved Get False
22:27:19.016 DriverVersion Get 1.6
22:27:19.016 CanFindHome Get False
22:27:19.018 DriverInfo Get HitecRoof - ASCOM Driver. Version: 1.6
22:27:19.018 DriverVersion Get 1.6
22:27:19.019 DriverInfo Get HitecRoof - ASCOM Driver. Version: 1.6
22:27:19.019 DriverVersion Get 1.6
22:27:19.517 Slewing Get False
22:27:20.017 Slewing Get False
22:27:20.017 ShutterStatus shutterClosed
22:27:20.017 Slewing Get False
22:27:20.018 Slaved Get False
22:27:20.018 CanFindHome Get False
22:27:20.519 Slewing Get False
22:27:21.019 Slewing Get False
22:27:21.019 ShutterStatus shutterClosed
22:27:21.019 Slewing Get False
22:27:21.019 Slaved Get False
22:27:21.019 CanFindHome Get False
22:27:21.520 Slewing Get False
22:27:22.020 Slewing Get False
22:27:22.020 ShutterStatus shutterClosed
22:27:22.020 Slewing Get False
22:27:22.020 Slaved Get False
22:27:22.020 CanFindHome Get False
22:27:22.521 Slewing Get False
22:27:23.023 Slewing Get False
22:27:23.023 ShutterStatus shutterClosed
22:27:23.023 Slewing Get False
22:27:23.023 Slaved Get False
22:27:23.023 CanFindHome Get False
22:27:23.524 Slewing Get False
22:27:24.025 Slewing Get False
22:27:24.025 ShutterStatus shutterClosed
22:27:24.025 Slewing Get False
22:27:24.025 Slaved Get False
22:27:24.025 CanFindHome Get False
22:27:24.039 Connected Get True
22:27:24.526 Slewing Get False
22:27:25.027 Slewing Get False
22:27:25.027 Slewing Get False
22:27:25.027 Slaved Get False
22:27:25.027 CanFindHome Get False
22:27:25.528 Slewing Get False
22:27:26.029 Slewing Get False
22:27:26.029 ShutterStatus shutterClosed
22:27:26.029 Slewing Get False
22:27:26.029 Slaved Get False
22:27:26.029 CanFindHome Get False
22:27:26.530 Slewing Get False
22:27:27.031 Slewing Get False
22:27:27.031 ShutterStatus shutterClosed
22:27:27.031 Slewing Get False
22:27:27.031 Slaved Get False
22:27:27.031 CanFindHome Get False
22:27:27.531 Slewing Get False
22:27:28.032 Slewing Get False


#19

Sorry but I don’t know the mean of the driver error. Try tu put a poth hub ascom between voyager and your driver, probably the poth can stabilize the communication. We can arrange tomorrow a remote connection if this can help me to have more idea to help you.


#20

Did you need help ? … i’m free
All the best
LO