TheSky6 connection issue

Hi,

I am new here. I just downloaded Voyager for trial. A quick search here does not show something similar, so I would like to ask.

So far I am able to connect to my Apogee camera via MaxIM DL in Vayoger. The next I tried is TheSky6, and I got trouble. When I tried to connect, Voyager shows the following error message:

ATTENTION ! Voyager cannot run all functionality !!!
16:28:53 719 - Planetarium Connection Error = Retrieving the COM class factory for component with CLSID {0E0015B2-8EB6-4CA1-8A19-1A8BA6540C64} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

Do you know how can I resolve this?

My operating system is Win11.

Thanks.

Wei-Hao

Hi,

you must activate and register your TheSky6 Application like server and enable it. You can refer to the SB support on how to do this. Or you can follow instruction for TheSkyX/TheSky64 here:Setup - Voyager Wiki

Menù and operation to do are similar.

If you need remote help ask to our support email.

All the best
Leonardo

All the best
Leonardo

Hi Leonardo,

Thank you. I have used my TS6 for about 15 years, and I have not realized about the registration. I will do that.

Thanks again.

Cheers,
Wei-Hao

Hi Wei-Hao,

this is necessary for allow 3rd part external application to interact with TheSky application.
Registration because server is exposed outside like DCOM component and must be activated with a flag because work on TCP-IP channel.

Welcome and allow me to congratulate you for your wonderful images.

All the best
Leonardo

Right. I checked the wiki link you provided, and only saw the TheSkyX and TheSky64 part. I didn’t find any menu items in my TheSky6. Could you tell me which external application I should use for this? Or do I have to upgrade to TheSkyX?

Voyager is the external application that will use TheSky6 from external.
There are instructions only for TheSkyX/64 because I dont have more TheSky6.
You can ask to SB support/documentation or ask us for a remote session to enable it because looking at menù I will remember where is exactly, probably in tools menù.

Probably this is the right list of operations to do:

  1. Start TheSky 6 Professional in admin mode.
  2. In TheSky’s Telescope menu, select Server Settings…
  3. In the Server Settings window, Remote client capabilities section, turn on all of the options (“allow” checkboxes).
  4. Click OK to close the Server Settings window.
  5. restart TheSky6

All the best
Leonardo

1 Like

Leo has it right. :slight_smile:

Thank you to both. It works.