Using MGPBox as Environmental Device


I am using an MGPBox ( with my 10Micron mount. I want to read the Temperature and Pressure from the device. It works in other programs (e.g. SGPro) but in Voyager I see wrong data (temperature -273.1 C, humidity 0%). I know that the settings are correct (COM number).

I don’t see any error message in the log file or such.

Does anybody use any of the MGBox devices with Voyager? Or any idea how to further debug this?


Hello Mark,

have you tried to talk with the producer ?
I think you have used the ascom driver (because we doesn’t have direct driver) so ascom is equal for all. Probably they doesn’t match the european standard ? If you can send to us your MGPBox we can debug it for you.

All the best

I also use an MGPBox and get the same readings with Voyager. I’ve not tried it with other software so can’t confirm if that is a general case or not. It’s not something I’ve been overly concerned about but it would be nice if it displayed the right figures.

Edit: With ASCOM debugging enabled the driver returns ‘0’ instead of the correct figure so it’s looking like an ObservingConditions driver issue:

10:33:47.714 ObservingConditions Starting initialisation
10:33:47.783 ObservingConditions Completed initialisation
10:33:47.792 InterfaceVersion Get 1
10:33:47.793 Description Get ASCOM ObservingConditions Driver for MGBox.
10:33:47.811 Connected Get False
10:33:47.812 Connected Set {0} (HEX[53][65][74][20][7B][30][7D])
10:33:47.812 Connected Set Connecting to port COM3
10:33:47.825 Humidity get
10:33:47.826 Temperature get
10:33:47.826 DewPoint get
10:33:47.827 AveragePeriod get - 0
10:33:47.827 CloudCover get - not implemented
10:33:47.830 Pressure get
10:33:47.830 RainRate get - not implemented
10:33:47.832 SkyBrightness get - not implemented
10:33:47.836 SkyQuality get - not implemented
10:33:47.838 SkyTemperature get - not implemented
10:33:47.839 StarFWHM get - not implemented
10:33:47.841 WindDirection get - not implemented
10:33:47.843 WindGust get - not implemented
10:33:47.845 WindSpeed get - not implemented
10:33:47.847 InterfaceVersion Get 1
10:33:47.849 Humidity get
10:33:47.849 Temperature get
10:33:47.849 DewPoint get
10:33:47.850 AveragePeriod get - 0
10:33:47.850 Pressure get
10:33:47.851 DriverVersion Get 6.2
10:33:47.857 DriverInfo Get Ascom Driver for MGBox. Version: 6.2
10:33:52.871 Humidity get
10:33:52.871 Temperature get
10:33:52.871 DewPoint get
10:33:52.872 AveragePeriod get - 0
10:33:52.872 Pressure get
10:33:57.881 Humidity get
10:33:57.881 Temperature get
10:33:57.881 DewPoint get
10:33:57.881 AveragePeriod get - 0
10:33:57.882 Pressure get
10:34:02.887 Humidity get
10:34:02.887 Temperature get
10:34:02.887 DewPoint get
10:34:02.887 AveragePeriod get - 0
10:34:02.888 Pressure get
10:34:07.931 Humidity get
10:34:07.931 Temperature get
10:34:07.931 DewPoint get
10:34:07.931 AveragePeriod get - 0
10:34:07.932 Pressure get
10:34:12.949 Humidity get


I’ve managed to get it working with Voyager. For me there were two issues:

  1. the ASCOM driver port setting is different to the app so I needed to go into the ASCOM setup within Voyager so set it to the same port, COM6 in my case.
  2. there seems to be some strange interaction between the MGBox software and The AAG Cloudwatcher - I had to close the CW app and restart after connecting Equipment in Voyager.

I hope this helps.


Edit: After a bit more digging…

I moved the port that CW was using from Serial port 3 to 7 and now the ASCOM conditions with the MGBox and AAG Cloudwatcher both work independently as they should. It seems that the MGBox ASCOM interface can be a bit fussy.

I have 3 COM Ports available in the ASCOM properties (COM1, COM3, COM4). The MGBox app itself only works if I use COM4. Is there a way to set it to a completely different port?


You should be able to reassign the com port in device manager, that’s what I did.


I had this issue at the start with my Mbox. It works if you don’t open the MBox app (which you would have to do with SGP) or if you want the Mbox app for display purposes, open it in administrator mode.

1 Like

Wow! Yes, that fixed it!!! Thanks Vertigo!!!

No problem glad to help.