Voyager 2.3.4 Release - Built 2021-09-17

Manual Download direct link:

Dropbox link:

Release 2.3.4 - Built 2021-09-17 - UPDATE INFO


NEW => DragScript → The ability to retrieve the coordinates from the sequence file for the various blocks has also been extended to the Voyager Array sequences
NEW => FITViewer → Added the ability to filter the original names of the auto opened files to save the JPG
NEW => OnTheFly Utility → Added utility for creating a solving data file starting from a CSV of points in altazimuth. Useful for the final elaboration of a model with external software
NEW => DragScript → Added to the Exposure block the possibility to report in the name of the FIT the position of the focuser
MOD => PHD2 → PHD2 command waiting timeout in Voyager had no effect on the Connection command
MOD => ASCOM Platform → IMPORTANT! WorkAround developed for the Handle Leak of the ASCOM Platform of the Astrometry library. The malfunction led to an anomalous consumption of operating system handles in PCs running H24 with the need for frequent reboots
BUG => FlatDevice → All the blocks with flat device operations were not executed correctly if only the flat device was connected, it was necessary to connect all the setup
BUG => Array → In the Array sequence configuration it was not possible to select gui time 0 for automatic
BUG => Mosaic Research & Survey Configuration-> The target in “Force Start with” was not stored correctly in case of selecting the last item from the list


NEW => DragScript → La possibilità di recuperare le coordinate dal file di sequenza per i vari blocchi è stato esteso anche alle sequenze di Voyager Array
NEW => FITViewer → Aggiunta la possibilità di filtrare i nomi originali dei file auto aperti di cui salvare il JPG
NEW => OnTheFly Utility → Aggiunta utility per la creazione di un file dati di solving a partire da un CSV di punti in altazimutale. Utile per l’elaborazione finale di un modello con software esterno
NEW => DragScript → Aggiunta al blocco Exposure la possibilità di riportare nel nome del FIT la posizione del focheggiatore
MOD => PHD2 → Il timeout attesa comandi di PHD2 in Voyager non aveva effetto sul comando di Connessione
MOD => ASCOM Platform → IMPORTANTE ! Sviluppato WorkAround per l’Handle Leak (thanks Vitali) della Piattaforma ASCOM della libreria Astrometry. Il malfunzionamento portava ad un consumo anomalo degli handle del sistema operativo nei PC in funzione H24 con necessità di riavvii frequenti
BUG => FlatDevice → Non venivano eseguiti correttamente tutti i blocchi con operazioni di flat device se era connesso il solo flat device, occorreva connettere tutto il setup
BUG => Array → Nella configurazione della sequenza Array non era possibile selezionare tempo di guida 0 per automatico
BUG => Mosaic Research & Survey Configuration-> Non veniva memorizzato correttamente il target in “Force Start with” in caso di selezione dell’ultima voce dall’elenco


Hey Leo - another great new release!

Do you know of any reports of the FITViewer crashing on startup with a .NET “Unhandled exception” error after upgrading to ASCOM 6.5 SP1 and 2.3.4? Interestingly it only became a problem after I reboot, until then everything was working fine after the upgrade to 6.5/2.3.4

I have a feeling that maybe 6.5 SP1 messed up something with .NET, but it’s hard to tell - running Windows 10 also means that I can’t reinstall it to “fix” the problem.

FITViewer doesn’t use any ASCOM library Paul.

All the best

Thanks Leo - I assumed it didn’t but I am wondering if the new SP1 somehow damaged my .NET setup as the FItViewer will not startup. Happy to log a formal support request with you, this sounds like it’s a “me” thing again.

Net Framework cannot be touched by a third part application like ASCOM … I think your is a configuration file access problem. Voyager generally use no crash code…if happens means usually an OS problem on system or an access resource failure. For the second be sure to add your application to your antivirus and defender exceptions.

Screen Shot 2021-09-25 at 3.24.16 pm

Thanks fo rate reply Leo - the only thing that changed from my system working to not working was the install of 2.3.4 and ASCOM 6.5 SP1 upgrade - it’s been working fine prior to that.

I’ll log a formal support request with you. I’ve tried de-installing and reinstalling the .NET extensions and the problem persists. I’ll try reinstalling 2.3.4 to see if that fixes it and if not will log a support request, thanks!

Paul, nothing is changed in FITViewer in 2.3.4
Like you can see it refere to a configuration system failure … and isn’t an exception generate directly by the code in FITViewer.

I suggest to use this workaround:

Or look at this:

All the best

1 Like

Thanks for the tip Leo - it was a folder called FITViewer in teh AppData folder - once I deleted that it worked again, thanks!

There WAS also a Leonardo_Orazi folder in AppData but I deleted that and it didn’t solve the problem.

I assume there must have been a bad shutdown or something that left a file that FITViewer didn’t like. Problem solved! Hope this helps others.

1 Like

I’ll add to FAQ , thanks. The folder of the FAQ I linked is related to Voyager.
This folder is not created or managed by our applications but from interactions between OS and Windows Manager GUI.

Thanks to you.

All the best

1 Like

Thanks so much for sharing this fix! I had a similar issue for some time on one of my systems. This has allowed me to resume using FITViewer.

1 Like