Voyager and SkyX with ME2 don't play nice. 4 10 minute images and SkyX terminates

Like the topic states, everything works well at first. Get really nice images. SkyX points and guides including calibration for four images, then the SkyX terminates and Voyager starts spamming error messages. I abort, disconnect, reconnect (letting voyager start the SkyX in admin mode or at least that box is checked on the exe file) start the dragscript again and 4 more images.

The issue seems like it is related to guiding. Sometimes when I try to reconnect the guider shows as connected to another program. Then I have to power off the hub and camera power then restart both to get Voyager to connect. I’ve considered using PHD2 but it doesn’t want to work well with SkyX and the ME2. Its a pulse guide versus directguide issue.

I previously used CCD Auto Pilot with Maxim and it worked fine. However then author of CCDAP has retired and is going to not do anymore updates for bugs or enhancements, so here I am :slight_smile:

Dear David,

this kind of problem coming from camera driver or similar inside TSX. We cannot help about.
We suggest to open a support request to the Software Bisque or use in Voyager different camera control.

Also I remember to you that official support is not provided by this forum.
Voyager cannot close TSX , if TSX disappear some low level driver inside throw a bad exception at OS level. If you want you can send log of Voyager if we are able to identify something useful for you.

For PHD2 and TSX I know so many use PHD2 for guiding without problem.
Probably the source of problem is the same and is related to your TSX configuration.

All the best

Hey David - I use the combination fo PHD2 and an MX and ME all day long and it’s fine with Voyager (at least as far as your issue is concerned).
I cant speak for TheSkyX guider, it’s never been great guiding software so I avoid it.

Happy shel you work on teh problem if you like.

1 Like

Thanks Paul

All The best

Ok, I think I solved the issue. As usual, it was the one wrong setting. I noticed there was a checkmark in the SkyX autoguider section for something like “make image download a priority” then an asterisk that led to a disclaimer “not recommended for guide camera”

Unchecked that, it came checked by default and changed the main camera to no camera even though it wasn’t supposed to be used. And presto it ran all night no issue. Hurray!

1 Like


I’d love a pointer or two on how to connect the SkyX/ME II and make them happy. I know at one point PHD 2 and SkyX we’re working together. I think the profile got corrupted somehow and I uninstalled and reinstalled it and updated the SkyX from a 2018 version to current version and somewhere in there, it broke them working together. I did enjoy the multistar guiding when it worked.

You need the latest X2Ascom driver from Ascom2XMount Adaptor Installer 6.2 – Software Bisque . If you have a TPoint model in place tick the inhibit sync button then tick can get pointing state and direct guide buttons. Now pick this driver as the mount in PHD2 and you should be good to go. Pick multi star guiding in PHD2 and I would run the guiding assistant to fine tune settings. It’s also worth enabling the predictive pec guiding algorithm. Make sure PHD2 can calibrate and guide before invoking it via Voyager. I normally run unguided with my MX but have used the above settings guided quite successfully.

1 Like

sorry been busy post-lockdown! drop me your email address in a DM and we can chat offline