Voyager with TheSkyX and Nexdome

My observatory is in a NexDome and has for some time been controlled by TheSkyX and everything works well. However the sequencing capabilities of TheSkyX are very primitive so I was hoping to use Voyager to improve this.

I am currently using the Voyager trial version and it works excellently except with regards to controlling the dome. When I connect the dome it, often but not always, starts to rotate for no apparent reason. Also, when I try to execute a sequence it fails because Voyager is waiting for the dome to respond but it never does.

The dome works flawlessly if controlled but TheSkyX and Voyager has no problem connecting but it just doesn’t control the dome - even though it says that the dome is slaved.

The first time I tried Voyager it failed to work with the dome. The second time I changed some configuration parameters and it worked. The next night it stopped working and the old problems returned.

Is there some way of seeing the messages that Voyager is sending to TheSkyX (and TheSkyX’s responses) so I can work out what is going wrong?

Not sure if you solved this. I had a similar problem with TheSkyX dome add-on and my Pulsar dome. I solved it by switching driver from x2 to ASCOM. (Thank you Leonardo).