Web Dashboard 1.0.15 beta

A new version of Web Dashboard is ready to use online and on Voyager 2.2.14 internal web server.

One of the main add of this version is the Rotator Panel. It shows two widgets for Rotator P.A. and Last Solved P.A… You can also send “Go” remote rotation command with degree input or fine movement buttons from the actual Rotator P.A.
This panels will auto hide if you don’t have a Rotator connected into your environment setup connection.

In this version:
[NEW] => Port selection is now a numerical input field. Default value is 5950
[NEW] => SSL switch activated, the protocol requires proper backend configuration to work.
[NEW] => Username and Password input fields for Voyager Login (not active, coming soon)
[NEW] => Virtual F.O.V. panel P.A. slider now has fine regulations buttons for 0.1 and 1 degree values.
[NEW] => Added Rotator Panel (beta) with two widgets for Rotator P.A. and Last Solved P.A… It includes a Go button for Rotate to degree with manual input and fine variations buttons for 0.1 and 1 degree from he actual Rotator P.A. This panel will be hidden automatically if you haven’t a rotator connected after successful Startup Environment connection.
[BUG] => Added startup actions delay for better initialization.
[BUG] => improved abort management for the last image preloader

This version requires Voyager 2.2.14


Hi Francesco,

I loaded Voyager 2.2.14 last night and used it for a session without issue. However Web dashboard will not connect when leaving the IP address blank using local host (same computer as running Voyager). I was able to connect to the Web Dashboard from a separate computer on my local LAN. Thanks to you guys for the new features.


The rotator panel looks awesome!



1 Like

Hi Jon,
nothing has changed into IP input field since the previous version.
Please make sure you have the address input field empty, not a whitespace, you should read the placeholder, this means the field are clean. I show some screenshot

Anyway, in the next version I’ll add a function to clean the whitespace into the IP input field.
Please give mi a confirmation, thanks.


Thank you Glenn, I really appreciate.
It’s almost completed and in the next version will be added also Remote Viking I/O panel.

Hi Francesco,
I just checked again with a clean reboot of my computer running Voyager. I just started Voyager and then went direct to the local host web dashboard by pressing the dashboard button. The IP address field is clean. The dashboard comes up on the screen. When pressing “connect” nothing happens. If I use a different computer on my local area network, no problem, connects fine.

All the settings to allow the web dashboard are verified in the voyager setup tab.

The localhost version seemed to work fine with the previous version of Voyager.



Attached is a screen shot of my setup and what I see when connecting via local host

The configuration seems to be right, my tests works, I could check in your pc with teamviewer if you want.
I write you in private.

Was the browser cache in dirty status, a press to F5 restart the normal connection process.
Thanks Jon to allow me to access from remote.

All the best


Yes! Thank you for doing this Leonardo!!


Thanks for the excellent work!

I have one question maybe related to the Web Dashboard use. Say if I created a RoboClip target and I want to change/edit/re-frame it, how would I do that? Right now if I click on the “Edit” button next to the target, it let’s me to change the name, group, and PA angle, but it doesn’t allow me to go back to Virtual FoV and re-frame it. Is there a way to do that?


1 Like

Hi Yizhou,
you can manually edit all of the fields, and save it, in Web RoboClip. But if you need to re-frame it you need to press the green icon (airplane icon) to load target into Virtual FoV, reframe it and save it again as a new one. After doing it, if you don’t need old version, you can delete it in row.

Thank you Francesco. That’s what I’ve been doing, just create new one and delete the old ones. Would be convenient if we can just update the previous target, but I guess a fairly low prio request. Appreciate the answering!

You are welcome Yizhou, I agree it could be useful to edit the target also by Virtual FoV, not only editing input fields, but I need to find a way that does not bring confusion in the user and accidentally edit of saved target. I’ve add this in low-priority todo list.

Francesco sorry,

I connect to the server via a win10 desktop pc and an android tablet.
Both connect but win10 has upgraded to v 1.0.15 beta, the tablet does not move from v 1.0.14 beta.
What should I do?

Thank you

Done … android has its own cache drain …