Webdashboard connection from remote machine

Hi there,

I’m trying to control the web dashboard from another host IP address but get the error: Connection error: Application Server Unavailable.
I have the both Voyager running on one machine host, and I’m trying to connect from another machine host on the same network.
It appears that the web dashboard can only be connected to/from the localhost of the Voyager installation.
If this a license limitation or a feature that has not yet been enabled?

Thank you for your help

You certainly can connect from a remote machine, are you putting in the correct IP address or name (I always use the IP address) before you try to connect? If you do not enter one it will try to connect to Voyager on the local machine instead of the remote one where it is actually running.

My apologies,

I actually managed to get this working by entering the host IP address of the Voyager install, and I can now connect to the Voyager system through the web dashboard.

Another win, is I can also access the webdashboard of reverse http tunnel using ngrok.io, which now grants me access to the Voyager host machine dashboard that is running behind Carrier ISP NAT.

Not working with https, which Im not sure why. Trying this method, I can enter the IP address, but cannot connect to Voyager. Suspect something backend not allowing https.

Not too secure for the meantime, but can use some basic http auth.

Very happy.
Thanks all.

EDIT: Hey Blue, yes, just worked that out. I was suspecting the localhost (blank entry would work, or 127.0.0.1) I missed using the IP of the Voyager install itself. Thanks

Hi again,

I encountered another issue with this and not sure if this might be something do to with Windows7 specifically.
I didn’t have any issues using a Windows 10 installation.

With remote http tunnelling using ngrok, I can load the web dashboard without issue on the W10 instance, and connect to the application server(connected), but on the W7 instance using the host IP address to connect it just times out without error connecting to the application server.

With both W10 and W7 instances they are currently set to use web port 2020, and 5950 with the application server.

I was able to confirm on the W10 instance that the Private Firewall Profile(if enabled) required an allow rule on the Voyager2 application.exe for the Voyager2 application to work correctly, but using the same settings, even disabling all firewall profiles/rules on the W7 instance I was unable to connect.
Windows firewall has three firewall zones(profiles) Public, Private, Domain.

For the W10 instance I have just one host IP address. 192.168.1.110 port=5950 for the Server container run.

However, with the W7 instance, it has two IP addresses, 192.168.6.74 for a wireless network, and 192.168.4.10 for an ethernet network. I can see that the preferred route for internet access is 192.168.6.74, so I’m unsure if its possibly a network address issue?
I am trying to connect to the application server using the host IP 192.168.6.74.

Probably is this a metric problem on 2 different interface and routing resolution , but really hard to understand. Try to disable one of the interface.

My suggestion is to use a VPN, i think you have not problem to install and use a OpenVPN environment.

All the best
Leonardo

Hi Leo,

Yes possible.

OpenVPN was my next course of action to try this out. Will do further testing and advise further.