Error connecting ioptron cem60

Quick question to see if anyone else has seen this with Voyager. This is the third time it has happened. Initial startup. All equipment connects including the cem60 mount. Everything is green. I assume everything is ok.

  1. Cartes Du Ceil will start but will not auto connect to the telescope, I think it should. Not sure
  2. If I try to move the telescope with voyager, I get an error that the mount is not connected. When I disconnect all and reconnect all, everything works fine the rest of the night. As far as I know, I have the latest ioptron ascom driver, just wondering if there is something in Voyager I am missing.


voyager_log.pdf (975.4 KB)

Attached is the log, I figure that may help

Hi Eric,
I use Voyager with the CEM60. The iOptron driver has a delayed connection to the mount - software connects to the iOptron driver, and then it connects to the mount a short time later. Sometimes the driver stops and prompts you for a COM port number (or to do a search for the COM port automatically). I don’t know if this is the root of your problem, but it seems possible to me. My sequence is to first bring up my planetarium (TheSkyX, in your case CdC) and connect to the CEM60. Then I bring up Voyager and connect. I don’t have any problems this way, I think it may be because the driver is already connected to the mount when you connect from Voyager.
Give it a try.

Thank you. I have done it manually in the past, it has just been recent that I have tried the more automated. I know what you mean with the delay and the prompt of port. I’m sure that has a lot to do with it. I will go back to starting it up first.

By the way, this is only my 4th time using Voyager and wow!! what a great piece of software.


Hello Eric, thanks you so much.

You can try connection again , Voyager retry to connect only the controls not connected.
This can be done also in DragScript. If you need help you can look here Safe Setup Connection with retry - DragScript example

Let me know


Thanks. i tried again last night and it didn’t work. I think the problem is that voyager reports connected on the first try. It displays green. It is only when you try a move operation that you get the message that it is not connected. I just went back to my old way of starting the ioptron outside of voyager first and everything is perfect after that.

Hello Eric,

if Voyager report mount connected in green this mean have opened connection using ASCOM driver and have done an handshake asking some data to mount and receive polling data correctly. If you lost communication during green status you’ll receive a lot of red error message in monitor and some functions doesn’t work in Voyager.

So this sound strange to me , probably is a good things to open a mail to IOptron support to understand if something to check in your configuration data in driver or Voyager do something bad using their ASCOM driver (they can ask to activate ASCOM log)

All the best