Out of memory error

I finally got the opportunity to use Voyager under the stars, and I am very pleased with how it went! It performed well throughout the night and I am growing to appreciate many aspects of the design and work flow.

I was able to get Robofocus “in place” to work very reliably but could not get local field focusing to work at all. (I use a ZWO ASI1600MM-cool camera.) I kept getting an error from the ZWO ASCOM driver indicating that the camera was out of memory. (I took a screenshot of the error but the screenshot is on my astro computer, and I don’t have access to it right now.) I adjusted the settings intended for slower cameras, but this did not seem to make a difference. I also adjusted settings within the ZWO driver, which also did not seem to matter.

I was able to use Robofocus without a single issue, and the camera took light frames all night long without a hiccup.

Has anyone else had this issue with local field autofocus?



Hi Glenn - from the Wiki:

AutoFocus https://voyager.tourstar.net/index.php?title=FAQ

  • LocalField autofocus fails with an out-of-memory error
    • Try using a smaller ROI or binning 2x2 instead of 1x1. The image is managed in memory using a Microsoft memory object that does not do garbage collection, so depending on what other programs are running and possibly using this memory, you may run out if your camera creates large images with each shot

Thank you for responding, Rowland.

I forgot to mention that I had already tried setting ROI to 90% and binning to 2 x 2. I could try higher binning but 2 x 2 is reasonable already. I could try decreasing the ROI further to see what happens.

Have you had this issue, too, Rowland?

Yes, I had it once. Setting the binning to 2x2 fixed it for me. I’m also using the ASI1600MM cool.

You said the ZWO driver reported the out of memory error? That might be a different issue. Maybe a screen capture or text of the error message would help? To make sure we’re talking about the same thing - or not!

If it is the same thing, Leo explained that Windows controls the shared memory object and available memory could depend on what else is running, so if there are other programs in the foreground or background that you could shut down, that might be worth trying.


1 Like

Glenn, binning 2 solve problem when happen with ASI. This mean cause is different.
Have you tried to restart your PC ? Probably the driver have internal problem in the instance.

All the best

Here is the error meaaage I was receiving. To be clear, the first image of local field autofocus captures just fine, and the error occurs when the second image is attempted.

I interpret this as a driver-level problem, but I am no expert.

Leo, does Voyager create an activity log (i.e. text file) that can be analyzed?

Here are the settings I have been using for local field.

I think the 14 march night something goes wrong in OS with ASI driver … they have a mode to manage memory that create problem with 32bit driver in heap. Depends on user PC … Probably if you retry doesn’t find more problem

Generally setting for large CCD can create memory problem , i have and idea how to work around it and i’ll do it … final solution must be to switch all to 64bit or 4.5 or higher MS framework, but this can create a lot of driver problems.

Also star recognition in Voyager use AI with a parallel processing and recursive clustering is fast and accurate but with memory cost.


1 Like

Bin in this setting is general … if you have filter … filter setting bin for LocalField bypass general setting.
This mean if you leave binning 1 in filter shot continue to use in bin1 and you not solve.

Put bin 2 in filter setting in VOyager for LocalField (each filter have dedicated setting)
not use ROI in bin2 (ROI setting is general not for filter)

1 Like

Hi Glenn - To answer your question about logs, yes - info about folders and log file location is in the Wiki here:


Sounds like Leo probably found your issue if your per-filter binning is still set to 1x1 - let’s hope that’s it!


1 Like

Thanks, Leo! I did not have bin 2 x 2 selected in Filter Setup, so I’m sure that will take care of the problem. Unfortunately, clouds are in the forecast for the next several days, so I will not be able to test the new setting.

If I may comment, having the option of setting binning for focus in two different locations (i.e. Filter Setup and Robofire Configuration > LocalField Mode) is a little confusing because one cannot know which setting takes precedence.

Rowland, thanks for pointing me to the log location. :slight_smile:

I am loving Voyager. I really value its clean, efficient design and amazing flexibility with DragScript. What an amazing scripting tool.

Kind regards,


Hi Glenn,

i’ll add a button in the localfield setting form to jump to filter management.
In anycase not everyone have a filter camera or using filter, in this case i need a general place where to put the setting. This is why you found this confusing. i’ll add better label.

Thanks Glenn, Voyager is just a little automation app. Happy you like.

1 Like

Good information! I’ve updated the FAQ in the Wiki about the two places to find binning settings for your camera depending on whether it has filters or not.

I have no financial interest in Voyager, but I think it deserves wider use. It’s great that you discovered it Glenn, and I hope you find ways to mention it when you post in general forums so other people can try it out. It has given me months of all-night unattended imaging without a hang or crash, something I can’t say for the many other programs I’ve tried :slight_smile: .



I was able to use local field autofocus over the weekend at a star party. I can confirm that changing the binning to 2 x 2 fixed the problem!

Kind regards,


Ok Glenn, i use a 16MPX camera (Moravian) and i never had problem on bin1 with localfield (just is to slow to download data with this camera and i go in bin2). Depends on driver and memory management and what else software you are using in your PC. I’m working on fixed slot memory to avoid problem but is not for now.

In anycase bin2 doesn’t change goodnees of focus.

1 Like

Thanks, Leo. Yes, local field auto focus kept my stars tack sharp all night long. It was fast and dependable. After a few nights of using Voyager, I consider autofocus to be one of its many strengths.

I’m glad you are working on a fix for the memory issue with ASI1600 cameras. I dare say it is the most popular astroimaging camera in use today. There will surely be others who will experience the same problem I had been having.

I do have some other comments and questions but will post those later in a separate thread.


I had a similiar issue with my ASI183MM with the latest ZWO driver. I’m not sure where the problem lies but reverting back to an older driver version (ASICamera Setup V6.0.3.18) fixed it for me.

Hope that helps

Thanks Robert … i found some drivers doesnt optimize heap memory.
32bit process with net 4.0 framework doesn’t have access to Heap memory optimization.

Thank you, Robert, I will try that.


Yes it was a strange one, it only gave me the error with localfield focusing which did have me scratching my head for a bit. I’m addicted to to localfield focusing now so I had to get it working !