Voyager Daily Build 2.2.1a for TSX users [CHANGED to 2.2.1b]

A daily build dedicated only to users of TheSkyX that have trouble with guided dithering.
Please let me know about feedback if work fine and send to me the log, i’ve add more debug info.

Download here:

All The Best
LO

2 Likes

Awesome Leo!! :smiley:

I hope this solve the question or i need to found a night to test on the field.

1 Like

Ty and I will test with his system tonight. :slight_smile: He is on the east coast of the US, so he should be up and running in 90 mins or so.

If you need help just whatsapp me !

1 Like

After last night test I released a new daily build:

I updated also the link in first message of thread.
I’ll wait for feedback … MANY THANKS to Bill and Tyrel

LO

Thank you so much for this! I’m excited to try this out the next time we have a clear night here.

Thanks! At the moment is very cloudy here, as soon as it clears I will give it a try.

Cheers,

Jose

First clear night i will test it (hopefully… it is already dewish here…)

Ty is installing it now. We should have a test done shortly.

So it now only dithers one time, but there is a strange behavior:

21:39:56 597 - Expose IC_1805_LIGHT_Lum_20s_BIN2_-25C_001_20191013_213956_509_PA343_W.FIT
21:40:16 556 - Download scheduled to start …
21:40:25 121 - Exposing 20 [s] ; Filter=Lum ; Type=LIGHT ; Binning=2 ; Speed Default ; ReadoutMode=Fast

Line one does not actually do anything with the camera. It sits there and waits, says something is downloading, then puts up the second exposing line, which actually does engage the shutter, and takes an image.

Ty is pulling the logs now to send over. Seems like we are almost there, in terms of the fix.

I get this:

22:32:47 907 - Start Dithering
22:32:49 011 - Dithering Started
22:33:49 278 - SubAction [Sequence - Start Dithering] Error : Dithering Action Settle Timeout ()
22:33:49 309 - Action Time [ATOMIC_GUIDE_DITHERING] => 1 [m] 1 [s]
22:33:49 338 - Action Time Mobile Mean [ATOMIC_GUIDE_DITHERING] => 0 [m] 10 [s]
22:33:49 392 - Timeout on Dithering Settle!!

What were you aggression settings set to in SkyX?

Can you send to me the log @Jose_Mtanous?
Low was changed and i dont found in what you report some message that must be there !

Have you used the 2.2.1b ?

Thanks
LO

I used TheSkyX to guide and dither last night using version 2.2.1b and it worked perfectly. No timeout errors or other problems at all. This is a massive plus for me as TheSky guides my Paramount better than I could ever get PHD2 to do plus the calibration is so quick I can now recalibrate before each target which I believe leads to better guiding. For my setup, I’m using a ASI1600MM-Pro running Voyager’s native driver and my guide camera is a ASI290 running the TheSkyX native driver at 2x2 bin. My aggression settings are at 5 and my min move is .32 arcsec. Thanks Leo for this fix!

2 Likes

Thank you so much for feedback.

All the best
LO

Hi Leo, Ive sent you the log directly to your email inbox.

Cheers,

José

1 Like

Aggression is set to 2 on both axis.

Jose - that will cause the dither correction time to be significant in SkyX. I do not believe it has fast correction for dithers. You will need to increase dither timeout to compensate.

Hello José,

thanks for log.

Looking inside i see for small dithering amount all work with long time near timeout:

2019/10/13 21:58:40 782 - DEBUG     - [TheSkyXGuideClass            ] - [StartDithering                               ] - Guide ShutdDown in status [cdStateAutoGuide]

2019/10/13 21:58:40 785 - DEBUG     - [TheSkyXGuideClass            ] - [WaitStatus                                   ] - TSXC.State = cdStateNone

2019/10/13 21:58:40 845 - SUBTITLE  - [Sequence                     ] - [DITHERING_Code                               ] - Start Dithering

2019/10/13 21:58:40 845 - DEBUG     - [TheSkyXGuideClass            ] - [StartDithering                               ] - Guide Stopped .. Changing Native Star Position [x=190.023313670107,y=337.745990815255]

2019/10/13 21:58:40 865 - DEBUG     - [TheSkyXGuideClass            ] - [StartDithering                               ] - AutoGuide Starting with Native New Position [x=193.658315420151,y=336.446002244949]

2019/10/13 21:58:41 221 - DEBUG     - [TheSkyXGuideClass            ] - [StartDithering                               ] - AutoGuide Started in status [cdStateAutoGuide]

2019/10/13 21:58:41 270 - INFO      - [Sequence - Start Dithering   ] - [DITHERING_Code                               ] - Dithering Started

2019/10/13 21:59:32 597 - DEBUG     - [GudingSystem                 ] - [EnableAdvancedWDGuida                        ] - ENABLED Advanced Guiding WD

2019/10/13 21:59:32 597 - INFO      - [Sequence - Start Dithering   ] - [SETTLE_DONE_WAIT_Code                        ] - **Dithering Completed and Settled (dx=3.635;dy=-1.3)**

For other values you had a timeout, timeout is 60sec for error of 1 pixel. Or you enlarge time or bigger allowed error or increase the Aggression like Bill suggest.

Value of 5 must work like for Mark.
Thank you so much again.

All the best
LO