Voyager with TheSkyX

Hi Leo and everyone else,

I hope this is the right category for my (first) post. I’ve heard good things about Voyager and want to try it with my equipment which consists of:

Mount: Paramount MX+
Telescope: GSO RC14
Camera: SBIG STT-3200ME with in-built filter wheel and off-axis guider
Focuser/Rotator: Optec Gemini
Software: TheSkyX with camera add on

I’m running Voyager 2.1.7a Build 2019-08-05 in demo mode on a new laptop (Win10 Home edition). When I get it set up properly I’ll change to trial mode. However I can’t get Voyager to start TSX automatically when I try to connect, see screen capture:

The “Listen for connections” check box is ticked in the TSX TCP Server window.
Both TSX and Voyager have been set to run as administrator, and both programs have been run in that mode several times.

TheSkyX.exe and Voyager2.exe have both been added to the Windows Defender Firewall allowed list. I’ve even turned the firewall off.

If TSX is already open (but not connected to the equipment) then Voyager seems to connect ok.

Can someone suggest where I have made a mistake? Cheers,


Hi Mark,

It might be that Voyager is running as a 32 bit app and TSX is running as a 64 bit app. On my system here I manually start TSX first and then Voyager.

New Zealand

Welcome Mark,

Voyager can only call the TSX function , TSX using DCOM tech to work with 3rd parts.
Depending on OS host TSX the OS can stop the DCOM functionallity due to the last patchs.
Also if the first time you flag the tcp connection in TSX not like admin the DCOM way to register can produce this side effect.

You can try to download the last version of TSX, or remove it and clear the register by all the TSX key but is a critical action i dont recommend to you.

Sorry but i dont have a solution, you can work around using a dragscript to start setup: a block to start TSX application and a block to connect setup, or you need manually to start TSX.

All the best

This is not a question of 32/64 bit but a DCOM configuration from OS.

Hi Leo,

I think we need an explanation of what DCOM is (or a link) and why we need it. I remember a while back I was having problems and it was due to 32bit applications running on a 64 bit machine. In my case it was Voyager I think running as a 32 bit app on my 64 bit PC with SkyX installed as a 64 bit application. I didn’t configure DCOM and though Voyager works well with SkyX, I could not get Voyager to launch it. So I launch SkyX manually first and then Voyager. But maybe I also need to do a DCOM configuration? Never heard of it so a good explanation or a link would be great to understand.


DCOM is a Windows technology used by TSX. All OS by Microsoft have this service running. A lot of application you use every day use this tech. I dont think user need explanation about because usually is managed by the developer (in this case TSX) also because you need to be a programmer. Microsoft found a lot of security problem in DCOM and do a blind patch about, also ASCOM was affected by but they fix the layer code of DCOM and now work ok. A user cannot manage the DCOM configuration is too complex. Software Bisque will be do some change about i think.

Anyway the problem is not 32/64 because a lot of us use the TSX with Voyager in a 64 bit without problem on start. Some version of Windows Defender (depend on patch of OS you have) can interfer with normal DCOM use. Its a borderline problem.

The best solution is to ask to TSX support if there is a workaround, personally i asked but without success. Nothing is possible to do in Voyager , at least use a Dragscript to start it.

All the best

Thanks Leo for the explanation. It helps to understand the interface between TSX and Voyager.


Thanks Leo,
I started TSX manually and Voyager connected to all the equipment ok. Weather has been poor recently but tonight look better so I’ll do some testing with OnTheFly. Cheers,

I’ll add a flag in setup for a process startup of TSX for who have this problem…like how Voyager do for PHD2.
I dont have any other solution than this.

All the best