Web Dashboard keep disconnecting?

Hi all,

We’ve been using Web Dashboards to visit/control our remote Array system very well until recently (~month?), we started to noticed that the WD keep disconnecting themselves. It’s disconnecting perhaps 5-10 mins after connection. It happens to multiple users in our team so likely not a personal PC setting issue.

We have been using 2.3.0 and later version Voyager; We tried multiple versions of WD (from 1015 to 1020) with same behavior; We do use login name & password for WD. “Web Server” is of course checked with proper port assigned. Mostly we use Chrome as broswer but did try Safari with same behavior.

Does anyone experiencing the same? Is there any settings we should check (in Voyager? In broswer settings? In router control?)? It could very well be a problem on our own end rather than Voyager but we are clueless on troubleshooting…

Thanks for any advices.

Yizhou

1 Like

I’m experiencing the same thing. Not sure what’s going on.

Thanks for confirming I am not alone!

There are no settings to change, check in Voyager and nothing has changed in the dashboard connection management. The dashboard works on websocket so it is more likely there are connectivity problems with micro-interruptions that close the connection. The webdashboard closes even if the web page from which it was called is no longer active. There is no reconnection mechanism.

If you have log about when you have disconnection (please report the timing) please send to support.
I will check if there is something can help you. I started a 6 remote dashboard to 6 remote observatory that I can contact … 4 are running … 2 are in idle. I will let you know if I experience disconnection, at now is a 20 minute of connection.

All the best
Leonardo

Hi all,
the websocket disconnection can be caused by an external connection down, but also if the browser/device gone in standby mode. I think this could be the case:


This happened on my test only when the pc gone in system standby, I’ve deliberately caused after 1 hour without problem connected.
We can implement an auto re-connection option for this kind of cases, but after received your log file we can also better investicate your specific issue, if there are any other problems.
Last two precisation:
The suggested browser for use Web Dashboard is Firefox and Chrome, even Microsoft Edge last version (based on Chromium) works well.
The support email address is at your disposal when you have problems, we will happy to help you, please use this instead of forum for a quick and efficent support.

Thanks for understanding,
we will update soon with a test version with auto connect/re-reconnect option.

Have a nice sunday.
Francesco

1 Like

Hi Francesco,

Can you advise how shall I check if that system standby is the problem? I am using Chrome as the broswer and my computer never goes to sleep/hibernate. I think I also set in Chrome to leave it always active. The Web dashboard keep disconnecting itself still…

Dear Yizhou,

We did some scruple tests that lasted even more than a week with several observatories without finding any disconnection. The cause of your problems is to be found in the connectivity that is offered to you or in the router that manages it. The browser-side connectivity is managed by the browser, the dashboard in addition to opening and closing can not do anything else, this for the design of any browser it is.

However, we are working on an automatic reconnection on the dashboard side as a work around. We’ll let you know.

All the best
Leonardo

1 Like

Hi Yizhou,
I add to what Leo has already said that the auto re-connect feature is ready and under testing. If you want I can send you a temporary link in private message for try it.
Best Regards
Francesco

Hi Yizhou, Hi to all.
I’ve published on a temporary URL the VWD version with auto reconnection option. I think it could be very useful also for using mobile device that goes in standby mode often.

[EDIT*] New 1.0.22c: http://www.starkeeper.it/wdash/1022c/
*previous version (1.0.22a) contained a bug: it required authentication or activation code. Now it’s solved, sorry for the inconvenience.

I repeat this is a temporary link, it will be removed when we’ll release the public version.

In the following screenshot the new option highlighted.

Please let us know your opionion/experience.

Best regards
Francesco

2 Likes

Thank you guys! I’ll give it a try!

1 Like